summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-04-19 11:19:14 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-04-19 11:35:47 +0200
commit2799cb060ccd96724ef5f627ce94ab74547de2b9 (patch)
treea75a0b9d6474336c8c1d446013a70d8dfdb10725 /dev-libs/hiredis
parentdev-libs/hiredis: fix tests for 1.1.0 (diff)
downloadgentoo-2799cb060ccd96724ef5f627ce94ab74547de2b9.tar.gz
gentoo-2799cb060ccd96724ef5f627ce94ab74547de2b9.tar.bz2
gentoo-2799cb060ccd96724ef5f627ce94ab74547de2b9.zip
dev-libs/hiredis: correct hiredis-test parameter
The -p parameter expects redis port, not PID. Tests still fail, but those issues were fixed in version 1.1.0, which is about to be stabilized, therefore, I don't think we have to spend time fixing them. Failures are most probably related to used redis server version, see comments in [1]. [1] https://github.com/redis/hiredis/commit/b455b33818be4dab51777433fcac0d15e0c221ec Closes: https://bugs.gentoo.org/864795 Closes: https://bugs.gentoo.org/866944 Closes: https://bugs.gentoo.org/880395 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-libs/hiredis')
-rw-r--r--dev-libs/hiredis/hiredis-1.0.2-r3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/hiredis/hiredis-1.0.2-r3.ebuild b/dev-libs/hiredis/hiredis-1.0.2-r3.ebuild
index b990a555460f..178cf593343d 100644
--- a/dev-libs/hiredis/hiredis-1.0.2-r3.ebuild
+++ b/dev-libs/hiredis/hiredis-1.0.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -66,7 +66,7 @@ src_test() {
_build hiredis-test
"${EPREFIX}"/usr/sbin/redis-server - <<< "${REDIS_TEST_CONFIG}" || die
- ./hiredis-test -h 127.0.0.1 -p ${REDIS_PID} -s ${REDIS_SOCK}
+ ./hiredis-test -h 127.0.0.1 -p ${REDIS_PORT} -s ${REDIS_SOCK}
local ret=$?
kill "$(<"${REDIS_PID}")" || die