summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/guiloader
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/guiloader')
-rw-r--r--dev-libs/guiloader/Manifest2
-rw-r--r--dev-libs/guiloader/guiloader-2.21.0.ebuild36
-rw-r--r--dev-libs/guiloader/guiloader-2.99.0.ebuild39
-rw-r--r--dev-libs/guiloader/metadata.xml16
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/guiloader/Manifest b/dev-libs/guiloader/Manifest
new file mode 100644
index 000000000000..fc34491bf60c
--- /dev/null
+++ b/dev-libs/guiloader/Manifest
@@ -0,0 +1,2 @@
+DIST guiloader-2.21.0.tar.bz2 306030 SHA256 149726e450d264c5f72754a68299f8740cdded9e205c0f4c8b94040be2d41d59 SHA512 247b80fcd6361bb9b76e67a006bae87c5a721d9a47fed61ac136bcff9e531da5dfe2251ad765dc9294862554d50702d58ac843f16200793f7ff94b70a24b349f WHIRLPOOL 2cdf9f332cb4f1f5e2d28dd1f1450845815ee84060e2408a11ed1777ac8d6780a69928a43e508c036ceab2e3e8abbf4d503aad31b6654b61ace36c95ae1c146e
+DIST guiloader-2.99.0.tar.xz 279816 SHA256 86c68b17150fcc7889000cbe5e71feee423970554a66ba77b89246edfc602ee2 SHA512 705c65b18fbbba2c10cc6835f8bd152d58ea0ebc1d87e0812051b65dd06123fdebdf2e67a040cc5dd4cce202fe2b6472781a5c29b46bfc5e122182ec49780a6e WHIRLPOOL b1c38c051b4b6f2b65060edc622c5152c0d723238473bf9a144069a38692b9d4907025a6c1fd66b39b586f165ed6b7661afd5d1f812192e2240efce327dddb73
diff --git a/dev-libs/guiloader/guiloader-2.21.0.ebuild b/dev-libs/guiloader/guiloader-2.21.0.ebuild
new file mode 100644
index 000000000000..fc387d6fe859
--- /dev/null
+++ b/dev-libs/guiloader/guiloader-2.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="library to create GTK+ interfaces from GuiXml at runtime"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND=">=x11-libs/gtk+-2.22:2
+ >=dev-libs/glib-2.26:2"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/{authors.txt,news.{ru,en}.txt,readme.{ru,en}.txt} || die
+}
diff --git a/dev-libs/guiloader/guiloader-2.99.0.ebuild b/dev-libs/guiloader/guiloader-2.99.0.ebuild
new file mode 100644
index 000000000000..28096aebedd8
--- /dev/null
+++ b/dev-libs/guiloader/guiloader-2.99.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="library to create GTK+ interfaces from GuiXml at runtime"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND="x11-libs/gtk+:3
+ >=dev-libs/glib-2.28:2"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{authors.txt,news.{ru,en}.txt,readme.{ru,en}.txt}
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-libs/guiloader/metadata.xml b/dev-libs/guiloader/metadata.xml
new file mode 100644
index 000000000000..dc110b391b58
--- /dev/null
+++ b/dev-libs/guiloader/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">GuiLoader is a high-performance and compact GuiXml loader library. This
+ library allows GTK+ applications to c reate GUI widgets and objects at
+ run-time from GuiXml resource files. GuiLoader is written in C language
+ as a GObject subclass and has a trivial language-independent API.
+ GuiLoader was designed to be easily wrapped for any language that has
+ GTK+ bindings.</longdescription>
+ <upstream>
+ <remote-id type="google-code">nothing-personal</remote-id>
+ </upstream>
+</pkgmetadata>