summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/dbus-c++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/dbus-c++')
-rw-r--r--dev-libs/dbus-c++/Manifest1
-rw-r--r--dev-libs/dbus-c++/dbus-c++-0.9.0-r2.ebuild63
-rw-r--r--dev-libs/dbus-c++/files/dbus-c++-0.9.0-gcc-4.7.patch38
-rw-r--r--dev-libs/dbus-c++/metadata.xml17
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-libs/dbus-c++/Manifest b/dev-libs/dbus-c++/Manifest
new file mode 100644
index 000000000000..39e2adbc325a
--- /dev/null
+++ b/dev-libs/dbus-c++/Manifest
@@ -0,0 +1 @@
+DIST libdbus-c++-0.9.0.tar.gz 466362 SHA256 bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61 SHA512 7acebbb4254b2886cc0f05c5ddeeeac0b5863c5552d32249463b89380b0b95b8225c80bd98b8c7fcaada42ab770b5eff41b15390cd0d78bf1ee322ac6c2de319 WHIRLPOOL 71df5476368591aa289ee35e5b5eacf6f9322bc5fb6c0180f18ff4deac28700d4903b54ac8a0208600062e147f7ae50c0865f7c1cb71a0b2219377120f73ffab
diff --git a/dev-libs/dbus-c++/dbus-c++-0.9.0-r2.ebuild b/dev-libs/dbus-c++/dbus-c++-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..eddd15187029
--- /dev/null
+++ b/dev-libs/dbus-c++/dbus-c++-0.9.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
+
+inherit autotools-multilib
+
+DESCRIPTION="Provides a C++ API for D-BUS"
+HOMEPAGE="http://sourceforge.net/projects/dbus-cplusplus/ http://sourceforge.net/apps/mediawiki/dbus-cplusplus/index.php?title=Main_Page"
+SRC_URI="mirror://sourceforge/dbus-cplusplus/lib${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc ecore glib static-libs test"
+
+RDEPEND="sys-apps/dbus[${MULTILIB_USEDEP}]
+ ecore? ( dev-libs/ecore )
+ glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/cppunit[${MULTILIB_USEDEP}]
+ virtual/pkgconfig"
+
+S=${WORKDIR}/lib${P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-4.7.patch #424707
+)
+
+multilib_src_configure() {
+ # not just using autotools-multilib_src_configure because of multilib_native... logic
+
+ # TODO : add ecore multilib support if/when it is multilibified
+ ECONF_SOURCE="${S}" econf \
+ --disable-examples \
+ $(multilib_native_use_enable doc doxygen-docs) \
+ $(multilib_native_use_enable ecore) \
+ $(use_enable glib) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ PTHREAD_LIBS=-lpthread
+ # ACX_PTHREAD sets PTHREAD_CFLAGS but not PTHREAD_LIBS for some reason...
+
+ if multilib_is_native_abi; then
+ # docs don't like out-of-source builds
+ local d
+ for d in img html; do
+ ln -s "${S}"/doc/${d} "${BUILD_DIR}"/doc/${d} || die
+ done
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use doc; then
+ dohtml -r "${S}"/doc/html/*
+ fi
+}
diff --git a/dev-libs/dbus-c++/files/dbus-c++-0.9.0-gcc-4.7.patch b/dev-libs/dbus-c++/files/dbus-c++-0.9.0-gcc-4.7.patch
new file mode 100644
index 000000000000..2d5771717248
--- /dev/null
+++ b/dev-libs/dbus-c++/files/dbus-c++-0.9.0-gcc-4.7.patch
@@ -0,0 +1,38 @@
+sniped from ChromiumOS
+
+https://bugs.gentoo.org/424707
+
+From 154f7861d19a2bd5c79c488f9989610971db451b Mon Sep 17 00:00:00 2001
+From: Han Shen <shenhan@google.com>
+Date: Thu, 31 May 2012 16:49:35 -0700
+Subject: [PATCH] Fixed dbus-c++ gcc 4.7 building problem.
+
+Just add "unistd.h" inclusion to eventloop-integration.h.
+
+BUG=None
+TEST=Manually built using gcc 4.7.
+
+Change-Id: I87bd1f90db6a4c974a5ed8134044e8be2034aff2
+Reviewed-on: https://gerrit.chromium.org/gerrit/24260
+Tested-by: Han Shen <shenhan@google.com>
+Reviewed-by: Yunlian Jiang <yunlian@chromium.org>
+Commit-Ready: Han Shen <shenhan@chromium.org>
+---
+ include/dbus-c++/eventloop-integration.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/dbus-c++/eventloop-integration.h b/include/dbus-c++/eventloop-integration.h
+index 5108340..1b56ab5 100644
+--- a/include/dbus-c++/eventloop-integration.h
++++ b/include/dbus-c++/eventloop-integration.h
+@@ -27,6 +27,7 @@
+
+ #include <cstring>
+ #include <errno.h>
++#include <unistd.h>
+ #include "api.h"
+ #include "dispatcher.h"
+ #include "util.h"
+--
+1.7.9.7
+
diff --git a/dev-libs/dbus-c++/metadata.xml b/dev-libs/dbus-c++/metadata.xml
new file mode 100644
index 000000000000..783d17f1efcc
--- /dev/null
+++ b/dev-libs/dbus-c++/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ dbus-c++ attempts to provide a C++ API for D-BUS.
+ </longdescription>
+ <use>
+ <flag name="ecore">Use Ecore integration</flag>
+ <flag name="glib">Use glib integration</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">dbus-cplusplus</remote-id>
+ </upstream>
+</pkgmetadata>