summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-08 00:43:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-08 00:44:30 +0100
commit6300842105e9abd59fc4746a423b08f9baa7991d (patch)
treee371931b7721bbe2070f98ac1daa2c0f1456d512 /dev-libs/crossguid
parentkde-misc/kdeconnect: Add missing qdbus RDEPEND providers (diff)
downloadgentoo-6300842105e9abd59fc4746a423b08f9baa7991d.tar.gz
gentoo-6300842105e9abd59fc4746a423b08f9baa7991d.tar.bz2
gentoo-6300842105e9abd59fc4746a423b08f9baa7991d.zip
dev-libs/crossguid: Re-add 0_pre20150817 for now
Cleanup depends on media-tv/kodi-19.x cleanup ... Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/crossguid')
-rw-r--r--dev-libs/crossguid/Manifest1
-rw-r--r--dev-libs/crossguid/crossguid-0_pre20150817.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/crossguid/Manifest b/dev-libs/crossguid/Manifest
index 8c7c4899206d..cbf759e557c4 100644
--- a/dev-libs/crossguid/Manifest
+++ b/dev-libs/crossguid/Manifest
@@ -1 +1,2 @@
DIST crossguid-0.2.2_p20190529.tar.gz 141660 BLAKE2B 0f78a8ab5a420297f666b3b8156d499a9141ec25c049d4d2bb2ba594dc585abe211a149b83c605cce4f5530207231a065d5f3a87a0c969781de8c6381afa2527 SHA512 f0a80d8e99b10473bcfdfde3d1c5fd7b766959819f0d1c0595ac84ce46db9007a5fbfde9a55aca60530c46cb7f8ef4c7e472c6191559ded92f868589c141ccaf
+DIST crossguid-0_pre20150817.tar.gz 46569 BLAKE2B 3384b6c507c4713f5ea0d6012138f3543445a42c7353e934e267b91275f7cf75720a446f5fe24f334b1022946f856a65f5c158d0036c999c761e626c1e30062a SHA512 823ca301f1d3b78a778649cd9169194d98dd33c65cadd5bfb9f86429e82049c99c17e09f093b92675981d2aac2aac25b60cbb157fad57a3e1bada826edd8ba0a
diff --git a/dev-libs/crossguid/crossguid-0_pre20150817.ebuild b/dev-libs/crossguid/crossguid-0_pre20150817.ebuild
new file mode 100644
index 000000000000..9c61857673ce
--- /dev/null
+++ b/dev-libs/crossguid/crossguid-0_pre20150817.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/graeme-hill/crossguid.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="8f399e8bd4252be9952f3dfa8199924cc8487ca4"
+ SRC_URI="https://github.com/graeme-hill/crossguid/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+fi
+
+DESCRIPTION="Lightweight cross platform C++ GUID/UUID library"
+HOMEPAGE="https://github.com/graeme-hill/crossguid"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+# We use libuuid from util-linux.
+DEPEND="sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" #575544
+
+e() { echo "$@"; "$@"; }
+
+src_compile() {
+ e $(tc-getCXX) \
+ ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} \
+ -std=c++11 \
+ -c guid.cpp -o guid.o \
+ -DGUID_LIBUUID \
+ || die
+
+ e $(tc-getAR) rs libcrossguid.a guid.o || die
+}
+
+src_install() {
+ insinto /usr/include
+ doins guid.h
+ dolib.a libcrossguid.a
+}