summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-22 20:18:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-22 22:17:14 +0100
commitf830a1e40beec1194592194e606936736f983922 (patch)
tree137cbe9252dd579cb495e735053977b971cf4518 /dev-lang
parentdev-lang/haxe: drop old 4.3.1 (diff)
downloadgentoo-f830a1e40beec1194592194e606936736f983922.tar.gz
gentoo-f830a1e40beec1194592194e606936736f983922.tar.bz2
gentoo-f830a1e40beec1194592194e606936736f983922.zip
dev-lang/haxe: bump to 4.3.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/haxe/Manifest1
-rw-r--r--dev-lang/haxe/haxe-4.3.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
index 2d54822a0901..599e56f150fd 100644
--- a/dev-lang/haxe/Manifest
+++ b/dev-lang/haxe/Manifest
@@ -1 +1,2 @@
DIST haxe-4.3.3.tar.gz 8405617 BLAKE2B 0c27eafd6af0615b47de8a7bdbff25fe15d8bbf80525ede273a4a430cedde6f0d6c9871ae581e2a7e8a87b56862f0c1b9f6f862a7cbfb68ac943ccbc3ae36878 SHA512 fea25ae2ba7433e2f39faae8e05538419e5dfbc519315c8e91b84a2d0a7c9e2ed380b92b21c23ff597797311cbb7a15276b5f4623fb65c6e3d4d8cc801a74e23
+DIST haxe-4.3.4.tar.gz 8409775 BLAKE2B 929797d71c23724c08c85957be8b39d6802d35990f70a85f8f7c309fa4505dae2b4b24e881ea8f55b02d68af4eb5fb7956c2562cdc5a8f201925a3029bd2cafd SHA512 77f08d5ecd2f0d08d4f44f186120a3f72eb51c712116d50d524f116d981b28fec4e5a03ef0d7c84bf0451caac76a37d642841202d01822cbb5f08981f12998ec
diff --git a/dev-lang/haxe/haxe-4.3.4.ebuild b/dev-lang/haxe/haxe-4.3.4.ebuild
new file mode 100644
index 000000000000..776b27a6ebe6
--- /dev/null
+++ b/dev-lang/haxe/haxe-4.3.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multi-target universal programming language"
+HOMEPAGE="https://haxe.org/
+ https://github.com/HaxeFoundation/haxe/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
+else
+ # Haxe-debian is a distribution variant then contains the required git modules.
+ SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/haxe-debian-upstream-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+RESTRICT="strip"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ >=dev-ml/luv-0.5.12:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-sha:=
+ dev-ml/ptmap:=
+ dev-ml/sedlex:=
+ dev-ml/xml-light:=
+
+ dev-lang/neko:=
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ net-libs/mbedtls:=
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-ml/camlp5
+ dev-ml/dune
+ dev-ml/findlib
+"
+
+QA_FLAGS_IGNORED="usr/bin/haxelib"
+QA_PRESTRIPPED="usr/bin/haxelib"
+
+src_configure() {
+ export OCAMLOPT="$(usex ocamlopt ocamlopt.opt ocamlopt)"
+}
+
+src_compile() {
+ emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
+ OCAMLOPT="${OCAMLOPT}" INSTALL_DIR="/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_DIR="/usr" install
+ dodoc *.md
+}