summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-08-15 11:22:26 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-15 11:22:26 +0100
commitf8107e34b0a0ca8fcd565e3d5b6f00ac3db48b12 (patch)
tree38c2d96f084eb5308545c2bde842cc88090675ab /dev-lang
parentdev-python/webob: Remove old (diff)
downloadgentoo-f8107e34b0a0ca8fcd565e3d5b6f00ac3db48b12.tar.gz
gentoo-f8107e34b0a0ca8fcd565e3d5b6f00ac3db48b12.tar.bz2
gentoo-f8107e34b0a0ca8fcd565e3d5b6f00ac3db48b12.zip
dev-lang/perl: Fix building when EROOT != ESYSROOT
I didn't understand the distinction when I added these lines 8 years ago! There is some remaining usage of EROOT in src_configure, which is technically not allowed, but I'm not sure whether ESYSROOT would make sense there either. Perhaps that code needs to move. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/perl-5.40.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/perl/perl-5.40.0.ebuild b/dev-lang/perl/perl-5.40.0.ebuild
index 462941f8d822..be1251b4c5a1 100644
--- a/dev-lang/perl/perl-5.40.0.ebuild
+++ b/dev-lang/perl/perl-5.40.0.ebuild
@@ -439,7 +439,7 @@ src_prepare() {
tc-is-static-only || src_prepare_dynamic
if use gdbm; then
- sed -i "s:INC => .*:INC => \"-I${EROOT}/usr/include/gdbm\":g" \
+ sed -i "s:INC => .*:INC => \"-I${ESYSROOT}/usr/include/gdbm\":g" \
ext/NDBM_File/Makefile.PL || die
fi
@@ -577,12 +577,12 @@ src_configure() {
use m68k && append-ldflags -Wl,-z,norelro
export BUILD_BZIP2=0
- export BZIP2_INCLUDE=${EROOT}/usr/include
- export BZIP2_LIB=${EROOT}/usr/$(get_libdir)
+ export BZIP2_INCLUDE=${ESYSROOT}/usr/include
+ export BZIP2_LIB=${ESYSROOT}/usr/$(get_libdir)
export BUILD_ZLIB=False
- export ZLIB_INCLUDE=${EROOT}/usr/include
- export ZLIB_LIB=${EROOT}/usr/$(get_libdir)
+ export ZLIB_INCLUDE=${ESYSROOT}/usr/include
+ export ZLIB_LIB=${ESYSROOT}/usr/$(get_libdir)
# allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
myndbm='U'