summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-09-13 16:02:10 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-09-13 16:03:17 +0100
commit01583dd1074e0e7566bf363735bc47875d642c03 (patch)
tree283b314658df89ad087c1b7fed293e2aecfedd81 /dev-lang
parentsys-libs/glibc: Filter -Wl,--dynamic-linker=* from LDFLAGS (diff)
downloadgentoo-01583dd1074e0e7566bf363735bc47875d642c03.tar.gz
gentoo-01583dd1074e0e7566bf363735bc47875d642c03.tar.bz2
gentoo-01583dd1074e0e7566bf363735bc47875d642c03.zip
dev-lang/python: Set --prefix when building host "mini" Python
Otherwise flags pointing to the target prefix are added to the sysconfigdata, which can break building the native extensions. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.13.ebuild1
-rw-r--r--dev-lang/python/python-3.11.5.ebuild1
-rw-r--r--dev-lang/python/python-3.12.0_rc2_p1.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.13.ebuild b/dev-lang/python/python-3.10.13.ebuild
index e4e3da709eef..67085bcef06b 100644
--- a/dev-lang/python/python-3.10.13.ebuild
+++ b/dev-lang/python/python-3.10.13.ebuild
@@ -261,6 +261,7 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --prefix="${BROOT}"/usr
--libdir="${cbuild_libdir:2}"
# Avoid needing to load the right libpython.so.
diff --git a/dev-lang/python/python-3.11.5.ebuild b/dev-lang/python/python-3.11.5.ebuild
index db78c59ef0d7..df3980352b02 100644
--- a/dev-lang/python/python-3.11.5.ebuild
+++ b/dev-lang/python/python-3.11.5.ebuild
@@ -250,6 +250,7 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --prefix="${BROOT}"/usr
--libdir="${cbuild_libdir:2}"
# Avoid needing to load the right libpython.so.
diff --git a/dev-lang/python/python-3.12.0_rc2_p1.ebuild b/dev-lang/python/python-3.12.0_rc2_p1.ebuild
index 417ddacff0f8..d9637d52d1fc 100644
--- a/dev-lang/python/python-3.12.0_rc2_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_rc2_p1.ebuild
@@ -249,6 +249,7 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --prefix="${BROOT}"/usr
--libdir="${cbuild_libdir:2}"
# Avoid needing to load the right libpython.so.