summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-16 23:57:31 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-17 01:44:32 +0200
commite6de0003818bfb772b19d24c4f8f693d42210ac1 (patch)
tree122083e879d565b05afb4a31de4d9547e12123f4 /dev-lang/fuzion
parentgames-engines/odamex: Bump to 10.6.0, drop old 10.4.0-r3 (diff)
downloadgentoo-e6de0003818bfb772b19d24c4f8f693d42210ac1.tar.gz
gentoo-e6de0003818bfb772b19d24c4f8f693d42210ac1.tar.bz2
gentoo-e6de0003818bfb772b19d24c4f8f693d42210ac1.zip
dev-lang/fuzion: bump to 0.090
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/fuzion')
-rw-r--r--dev-lang/fuzion/Manifest1
-rw-r--r--dev-lang/fuzion/fuzion-0.090.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-lang/fuzion/Manifest b/dev-lang/fuzion/Manifest
index 429e6db3ff78..98c2fbbae876 100644
--- a/dev-lang/fuzion/Manifest
+++ b/dev-lang/fuzion/Manifest
@@ -1,3 +1,4 @@
DIST fuzion-0.086.tar.gz 994894 BLAKE2B e698ea7b8de215c55e84e0f55f405156d5c386c1001c7b29e0c7c49e7a7e7babf7cb64cf30726a24aa7b6ccdc0eaf01cc543867361e2554f258d76be1fc08b97 SHA512 6d2df12d1dced9c5a61bb183767fc205ddbc0d04db8cae3f5e3eabd9ab60f18b3c2b3fa8f57702dc792882b1a6f79da1cfcb7801d84ecc2cff1844a4bc226f67
DIST fuzion-0.088.tar.gz 1123270 BLAKE2B 3d68c136a862c02955b4a15e6cfe4d41a63a106c47289f7fdfe0af2b0119ebe26cbd9c6920c8b5311c756264bdd33d46f4b1108869427f83d55a350c2ab52e6f SHA512 b0fb1ea4175912684b4759ec58a91bc25d963fa2fa6234116fa91a63d757d9af5da9e20a3fdcc340fe956c01026d4b74c7a12dac40a0b7826d74c567b4e3383a
DIST fuzion-0.089.tar.gz 1235399 BLAKE2B b6814b9032e06481c4801c4519423f5019febb46390596941d3811fd053ceab66b3612cd6185fbda71eb14a6b1299bca80b572f27f90729a3713aad3ec1f675d SHA512 4eb7389c4346f15a8a75344d448f6ec35ae91615daba57a8cc2f220a7f6827fcf1de569da2dcf573f8a645640e3f2cb8e2c2a4acd9ad83fd83deca2addd75bdc
+DIST fuzion-0.090.tar.gz 1271502 BLAKE2B 88d97759fb1213cdb2a428b6fdb4b3f2a662295530a07765b10b1308608d63d8e75ca001d10f07d92a05c0e6c8d6df491edc9f8a981727255df8cba5ca0f4ca7 SHA512 4f49c2673bfa36321688ce7b5d26f74b57b84b1b95dc5e67c9c3c526a92e6cdd6fc7777e3814117982b29198e5de500250000fa58387d91085f602fe037cf948
diff --git a/dev-lang/fuzion/fuzion-0.090.ebuild b/dev-lang/fuzion/fuzion-0.090.ebuild
new file mode 100644
index 000000000000..92e01df35d36
--- /dev/null
+++ b/dev-lang/fuzion/fuzion-0.090.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2
+
+DESCRIPTION="A language with a focus on simplicity, safety and correctness"
+HOMEPAGE="https://fuzion-lang.dev/
+ https://github.com/tokiwa-software/fuzion/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/tokiwa-software/${PN}.git"
+else
+ SRC_URI="https://github.com/tokiwa-software/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/jre-21:*
+ dev-libs/boehm-gc
+"
+DEPEND="
+ virtual/jdk:21
+"
+BDEPEND="
+ test? (
+ sys-devel/clang:*
+ )
+"
+
+DOCS=( README.md release_notes.md )
+
+src_prepare() {
+ java-pkg-2_src_prepare
+
+ # Remove bad tests.
+ local -a bad_tests=(
+ basicIntegers
+ nom
+ onesCount
+ process
+ reg_issue3178
+ sockets
+ )
+ local bad_test
+ for bad_test in "${bad_tests[@]}" ; do
+ rm -r "${S}/tests/${bad_test}" || die "failed to remove test ${bad_tests}"
+ done
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 run_tests_parallel
+}
+
+src_install() {
+ # Remove unnecessary files from build directory. bug #893450
+ local toremove
+ local toremove_path
+ for toremove in tests run_tests.{failures,results} ; do
+ toremove_path="${S}/build/${toremove}"
+
+ if [[ -e "${toremove_path}" ]] ; then
+ rm -r "${toremove_path}" || die "failed to remove ${toremove_path}"
+ fi
+ done
+
+ insinto "/usr/share/${PN}"
+ doins -r build/.
+ insopts -m755
+ doins -r build/bin
+
+ local exe
+ for exe in fz fzjava ; do
+ dosym -r "/usr/share/${PN}/bin/${exe}" "/usr/bin/${exe}"
+ done
+
+ einstalldocs
+}