summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-19 20:28:14 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-19 21:32:11 +0200
commitc83357b8a831e17aa628222bd34fb934af82d2b8 (patch)
tree6dab96680f42b4c6436ca6fe29037f3b0b38878a /dev-lang/dafny-bin
parentdev-java/metainf-services: add 1.9 (diff)
downloadgentoo-c83357b8a831e17aa628222bd34fb934af82d2b8.tar.gz
gentoo-c83357b8a831e17aa628222bd34fb934af82d2b8.tar.bz2
gentoo-c83357b8a831e17aa628222bd34fb934af82d2b8.zip
dev-lang/dafny-bin: bump to 3.7.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/dafny-bin')
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-3.7.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index 6e4055cab706..554e14530b71 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1 +1,2 @@
DIST dafny-3.7.1-x64-ubuntu-16.04.zip 76008449 BLAKE2B 5685dcc04e750960fa9bed536d6fae8f70979be899349eaab54bb7045a6e6a9849988be10db3ad33c9096a8d91d17f7b055e50507f736a169aa4fdcb6654b8f6 SHA512 689f3a125e336806c7fe15a8e0cc95e3242f99b719bfae57715313699880c21b13cf2eddfe4163e40da8de20f81c7148dce132dbc511b7a5c2320c1e96d2040a
+DIST dafny-3.7.2-x64-ubuntu-16.04.zip 76166815 BLAKE2B a0b2531dedbe413298b6d92a65c854d70785d8732688d1e3556a5e5dc8c268b36dbb994e35960f2a18ecf40e64a6ff0912fa8df79beb6f2f81164be51907d262 SHA512 e472b1c848aece2980e67134a27bc1cab4a531b048790b7b36638e618d59f3f3e8ddcb538cd24723135266899a02b7c8952a73d81c4848e672c21c99c40c5af0
diff --git a/dev-lang/dafny-bin/dafny-bin-3.7.2.ebuild b/dev-lang/dafny-bin/dafny-bin-3.7.2.ebuild
new file mode 100644
index 000000000000..8601d4b64977
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-3.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-16.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Binaries are compiled only for x86_64.
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/dafny
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}