summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-07 13:18:19 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-07 13:18:19 +0200
commite4debfd4452b10ce467c767229d7884349b82161 (patch)
treebdc18441b21f4abd17bfacab3692dcc8db953a7b /dev-java
parentdev-util/intel-graphics-compiler: bypass opencl-clang version check (diff)
downloadgentoo-e4debfd4452b10ce467c767229d7884349b82161.tar.gz
gentoo-e4debfd4452b10ce467c767229d7884349b82161.tar.bz2
gentoo-e4debfd4452b10ce467c767229d7884349b82161.zip
dev-java/tomcat-native: bump to 1.2.25
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/tomcat-native/Manifest1
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.2.25.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-java/tomcat-native/Manifest b/dev-java/tomcat-native/Manifest
index b47850dc15da..2f49e6a6b7a1 100644
--- a/dev-java/tomcat-native/Manifest
+++ b/dev-java/tomcat-native/Manifest
@@ -1 +1,2 @@
DIST tomcat-native-1.2.24-src.tar.gz 419572 BLAKE2B 572f6d64b8f4c22ed1ab68efcec5cd1c57fe01e7b0830dea979039cb702a2930458e7bb31abdeddcacc6d673513c896ca46d28ece681c6c42938498351962b36 SHA512 5dae151a60f8bd5a9a29d63eca838c77174426025ee65a826f0698943494dd3656d50bcd417e220a926b9ce111ea167043d4b806264030e951873d06767b3d6f
+DIST tomcat-native-1.2.25-src.tar.gz 421399 BLAKE2B 5033b389cfb8b2899fe57c75f5d6d6bf77f4646f3c17aed51109c30760fa5642a8bfa5137ff5f97c571a853b0ae5b1b16244bf286655b6b252ca7ad4c2e3892a SHA512 e121c0a18c51b5f952833df44c3a0add1f9a6e1b61e300abbafa0bc7e8f32296e64c9f81e9ad7389c1bd24abc40739e4726a56158d08e33b7ef00e5fa8a1d33d
diff --git a/dev-java/tomcat-native/tomcat-native-1.2.25.ebuild b/dev-java/tomcat-native/tomcat-native-1.2.25.ebuild
new file mode 100644
index 000000000000..2dd1db52c691
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.2.25.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Allows Tomcat to use certain native resources for better performance"
+HOMEPAGE="https://tomcat.apache.org/"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/apr:1=
+ dev-libs/openssl:0=
+ >=virtual/jre-1.8"
+
+DEPEND=">=virtual/jdk-1.8
+ test? ( dev-java/ant-junit:0 )"
+
+S=${WORKDIR}/${P}-src
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_configure() {
+ local myeconfargs=(
+ --with-apr="${EPREFIX}"/usr/bin/apr-1-config
+ --with-ssl="${EPREFIX}"/usr
+ )
+
+ cd native || die
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ eant jar
+
+ cd native || die
+ default
+}
+
+src_install() {
+ java-pkg_newjar "dist/${P}.jar" "${PN}.jar"
+
+ cd native || die
+ default
+
+ ! use static-libs && find "${D}" -name '*.la' -delete || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+pkg_postinst() {
+ elog "For more information, please visit"
+ elog "https://tomcat.apache.org/tomcat-9.0-doc/apr.html"
+}