summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xsd2jibx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xsd2jibx')
-rw-r--r--dev-java/xsd2jibx/Manifest1
-rw-r--r--dev-java/xsd2jibx/files/build.xml69
-rw-r--r--dev-java/xsd2jibx/files/xsd2jibx-0.2a_beta-freemind.patch74
-rw-r--r--dev-java/xsd2jibx/metadata.xml8
-rw-r--r--dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild54
5 files changed, 206 insertions, 0 deletions
diff --git a/dev-java/xsd2jibx/Manifest b/dev-java/xsd2jibx/Manifest
new file mode 100644
index 000000000000..b7df9359c3e2
--- /dev/null
+++ b/dev-java/xsd2jibx/Manifest
@@ -0,0 +1 @@
+DIST xsd2jibx-beta2a.zip 961258 SHA256 615d573d944d361dfa23ff1099c543c78fae1943af0735c7a7743a0472c865db SHA512 d525b5e71358c4ce259d7e65abe5ee0214b89093d209c07861f4069919d6c13ffae292b5db80a6f01b8451363aa6b40706beadd04f663bbf1224aaf3bed5b0a2 WHIRLPOOL 7fda5e53a5d96422edd679cd489038760951a39afc2337dac4ce0d103e33ad293c8fad558fed5a3d4626f804050b8bd1d331a727579fc3ee84d74f80526eab2f
diff --git a/dev-java/xsd2jibx/files/build.xml b/dev-java/xsd2jibx/files/build.xml
new file mode 100644
index 000000000000..b41ca64cf949
--- /dev/null
+++ b/dev-java/xsd2jibx/files/build.xml
@@ -0,0 +1,69 @@
+<?xml version="1.0"?>
+
+<project basedir="." default="jar">
+
+ <!-- JiBX binding compiler task definition -->
+ <property environment="env"/>
+ <property name="jibxhome" value="${env.JIBX_HOME}"/>
+ <taskdef name="bind" classname="org.jibx.binding.ant.CompileTask">
+ <classpath>
+ <pathelement location="${jibxhome}/lib/bcel.jar"/>
+ <pathelement location="${jibxhome}/lib/jibx-bind.jar"/>
+ <pathelement location="${jibxhome}/lib/jibx-run.jar"/>
+ <pathelement location="${jibxhome}/lib/jibx-extras.jar"/>
+ <pathelement location="${jibxhome}/lib/xpp3.jar"/>
+ </classpath>
+ </taskdef>
+
+ <!-- compile the class files -->
+ <target name="compile">
+ <delete quiet="true" dir="${basedir}/classes"/>
+ <mkdir dir="${basedir}/classes"/>
+ <javac srcdir="${basedir}/src/main"
+ destdir="${basedir}/classes"
+ excludes="org/jibx/xsd2jibx/GeneratorAntTask.java"
+ debug="true"
+ deprecation="on">
+ <classpath>
+ <fileset dir="${basedir}/lib">
+ <include name="*.jar"/>
+ </fileset>
+ <fileset dir="${jibxhome}/lib">
+ <include name="jibx-run.jar"/>
+ <include name="xpp3.jar"/>
+ </fileset>
+ </classpath>
+ </javac>
+ <copy todir="${basedir}/classes/org/jibx/xsd2jibx">
+ <fileset dir="${basedir}/src/main/org/jibx/xsd2jibx" includes="**/*.xsl"/>
+ </copy>
+ </target>
+
+ <!-- bind the class files -->
+ <target name="bind" depends="compile">
+ <echo message="Running binding compiler..."/>
+ <bind verbose="true" load="true">
+ <bindingfileset dir="${basedir}/src/main/org/jibx/xsd2jibx">
+ <include name="xsd.jibx.xml"/>
+ <include name="jibx.jibx.xml"/>
+ </bindingfileset>
+ <classpathset dir="${basedir}/classes"/>
+ </bind>
+ </target>
+
+ <target name="javadoc" description="Produce JavaDoc">
+ <javadoc sourcepath="${basedir}/src/main" destdir="${basedir}/api"/>
+ </target>
+
+ <!-- Build the jar files for the distribution -->
+ <target name="jar" depends="bind">
+ <delete file="${basedir}/lib/xsd2jibx.jar" quiet="true"/>
+ <jar jarfile="${basedir}/lib/xsd2jibx.jar" basedir="${basedir}/classes">
+ <manifest>
+ <attribute name="Main-Class" value="org/jibx/xsd2jibx/Generate"/>
+ <attribute name="Class-Path" value="commons-lang-2.0.jar commons-logging-1.0.4.jar jaxme-js-0.3.jar log4j-1.2.8.jar jibx-run.jar xpp3.jar"/>
+ </manifest>
+ </jar>
+ </target>
+
+</project>
diff --git a/dev-java/xsd2jibx/files/xsd2jibx-0.2a_beta-freemind.patch b/dev-java/xsd2jibx/files/xsd2jibx-0.2a_beta-freemind.patch
new file mode 100644
index 000000000000..bcd67e9eece4
--- /dev/null
+++ b/dev-java/xsd2jibx/files/xsd2jibx-0.2a_beta-freemind.patch
@@ -0,0 +1,74 @@
+Index: src/main/org/jibx/xsd2jibx/JSource.java
+===================================================================
+RCS file: /cvsroot/jibx/xsd2jibx/src/main/org/jibx/xsd2jibx/JSource.java,v
+retrieving revision 1.6
+diff -u -B -r1.6 JSource.java
+--- src/main/org/jibx/xsd2jibx/JSource.java 19 Feb 2005 20:02:31 -0000 1.6
++++ src/main/org/jibx/xsd2jibx/JSource.java 6 May 2007 21:16:33 -0000
+@@ -89,6 +89,12 @@
+ jm.addParam(jqname, element.getFieldName());
+ jm.addLine(element.getFieldList() + ".add(" + element.getFieldName() + ");");
+
++ // create add to position method:
++ jm = source.newJavaMethod(element.getAddPositionMethod(), JQName.VOID.getJavaQName(), PUBLIC);
++ jm.addParam(JQName.INT.getJavaQName(), "position");
++ jm.addParam(jqname, element.getFieldName());
++ jm.addLine(element.getFieldList() + ".add(position, " + element.getFieldName() + ");");
++
+ // create getMethod
+ jm = source.newJavaMethod(element.getGetMethod(), jqname, PUBLIC);
+ jm.addParam(JQName.INT.getJavaQName(), "index");
+@@ -97,6 +103,13 @@
+ //create size method
+ jm = source.newJavaMethod(element.getSizeMethod(), JQName.INT.getJavaQName(), JavaSource.PUBLIC);
+ jm.addLine("return " + element.getFieldList() + ".size();");
++
++ //create clear method
++ jm = source.newJavaMethod(element.getClearMethod(), JQName.VOID.getJavaQName(), JavaSource.PUBLIC);
++ jm.addLine(element.getFieldList() + ".clear();");
++ //create unmodified method
++ jm = source.newJavaMethod(element.getListMethod(), "java.util.List", JavaSource.PUBLIC);
++ jm.addLine("return java.util.Collections.unmodifiableList("+element.getFieldList() + ");");
+ } else { // it is not a collection
+ newBeanProperty(element);
+ }
+Index: src/main/org/jibx/xsd2jibx/XsdElement.java
+===================================================================
+RCS file: /cvsroot/jibx/xsd2jibx/src/main/org/jibx/xsd2jibx/XsdElement.java,v
+retrieving revision 1.6
+diff -u -B -r1.6 XsdElement.java
+--- src/main/org/jibx/xsd2jibx/XsdElement.java 19 Feb 2005 20:02:31 -0000 1.6
++++ src/main/org/jibx/xsd2jibx/XsdElement.java 6 May 2007 21:16:33 -0000
+@@ -60,6 +60,12 @@
+ return sb.toString();
+ }
+
++ public String getAddPositionMethod() {
++ StringBuffer sb = new StringBuffer("addAt");
++ sb.append(NameUtil.toUpperCamelCase(getJavaName()));
++ return sb.toString();
++ }
++
+ public String getSizeMethod() {
+ StringBuffer sb = new StringBuffer("size");
+ sb.append(NameUtil.toUpperCamelCase(getJavaName()));
+@@ -67,6 +73,19 @@
+ return sb.toString();
+ }
+
++ public String getClearMethod() {
++ StringBuffer sb = new StringBuffer("clear");
++ sb.append(NameUtil.toUpperCamelCase(getJavaName()));
++ sb.append(NameUtil.addListSuffix);
++ return sb.toString();
++ }
++ public String getListMethod() {
++ StringBuffer sb = new StringBuffer("getList");
++ sb.append(NameUtil.toUpperCamelCase(getJavaName()));
++ sb.append(NameUtil.addListSuffix);
++ return sb.toString();
++ }
++
+ protected void importRef() {
+
+ if (this.ref != null) {
diff --git a/dev-java/xsd2jibx/metadata.xml b/dev-java/xsd2jibx/metadata.xml
new file mode 100644
index 000000000000..bc6fbe14e0bb
--- /dev/null
+++ b/dev-java/xsd2jibx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jibx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild b/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild
new file mode 100644
index 000000000000..42b8a66673f4
--- /dev/null
+++ b/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+MY_PV="beta2a"
+
+DESCRIPTION="JiBX binding and code from schema generator"
+HOMEPAGE="http://jibx.sourceforge.net/xsd2jibx/"
+SRC_URI="mirror://sourceforge/jibx/${PN}-${MY_PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+COMMON_DEP="dev-java/commons-logging:0
+ dev-java/xpp3:0
+ dev-java/jaxme:0
+ dev-java/jibx:0
+ dev-java/commons-lang:2.1"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ cp "${FILESDIR}/build.xml" .
+ # patch from freemind authors, freemind won't build without it
+ # they sent upstream (that's how I found it) which said he's preparing
+ # complete rewrite. It only adds non-abstract functionality.
+ epatch "${FILESDIR}/${P}-freemind.patch"
+
+ cd "${S}/lib"
+ rm -v *.jar || die
+ java-pkg_jar-from commons-logging,xpp3,jaxme,jibx,commons-lang-2.1
+}
+
+EANT_ANT_TASKS="jibx"
+EANT_EXTRA_ARGS="-Djibxhome=${EPREFIX}/usr/share/jibx/"
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ dohtml -r docs/*
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc src/main/org
+}