summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/touchgraph-graphlayout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/touchgraph-graphlayout')
-rw-r--r--dev-java/touchgraph-graphlayout/Manifest1
-rw-r--r--dev-java/touchgraph-graphlayout/metadata.xml8
-rw-r--r--dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/touchgraph-graphlayout/Manifest b/dev-java/touchgraph-graphlayout/Manifest
new file mode 100644
index 000000000000..cdb670712cec
--- /dev/null
+++ b/dev-java/touchgraph-graphlayout/Manifest
@@ -0,0 +1 @@
+DIST TGGL_122_jre11.zip 202777 SHA256 52651209d131f6c012a4a5735271a8f9e572d8fbbece44b643680d725da9c853 SHA512 5c638972264ada2cb91ea1667c0b770629120a01496f7834ef3e4999ad5867ff911e772ea1361e33c168d8681c6f19f46ada33ea637daf4474f66a5cc97610a5 WHIRLPOOL 89180950669d0840af937e983b56a06e58eae6105e70cfb58ae9f11e18efa18981d1e40226536612b25031dfa2c44f65b30dfee8f30083bb2226b59aed4f3957
diff --git a/dev-java/touchgraph-graphlayout/metadata.xml b/dev-java/touchgraph-graphlayout/metadata.xml
new file mode 100644
index 000000000000..ef50d3af37e1
--- /dev/null
+++ b/dev-java/touchgraph-graphlayout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">touchgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22.ebuild b/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22.ebuild
new file mode 100644
index 000000000000..eda9479ab357
--- /dev/null
+++ b/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN="TGGraphLayout"
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2
+
+DESCRIPTION="TouchGraph provides a set of interfaces for graph visualization"
+HOMEPAGE="http://touchgraph.sourceforge.net"
+SRC_URI="mirror://sourceforge/touchgraph/TGGL_${PV//./}_jre11.zip"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() {
+ mkdir -p bin || die
+ ejavac -d bin `find com -name "*.java" || die`
+ `java-config -j` cvf ${MY_PN}.jar -C bin . || die
+}
+
+src_install() {
+ java-pkg_newjar ${MY_PN}.jar
+ dodoc "TGGL ReleaseNotes.txt" || die
+ use source && java-pkg_dosrc com
+}