summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/snip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/snip')
-rw-r--r--dev-java/snip/Manifest1
-rw-r--r--dev-java/snip/files/snip-0.11-build.xml.patch13
-rw-r--r--dev-java/snip/metadata.xml12
-rw-r--r--dev-java/snip/snip-0.11.ebuild39
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/snip/Manifest b/dev-java/snip/Manifest
new file mode 100644
index 000000000000..89d12fe59b4f
--- /dev/null
+++ b/dev-java/snip/Manifest
@@ -0,0 +1 @@
+DIST snip-0.11-src.tar.gz 23270 SHA256 c8d0e299010e0582d69b3c0567b89190cfab8b123b4bc61920c721c1b82240e7 SHA512 b782559bd542e4d79fa19e351d2e04331f002d139ecc4ae957ceb282c2fc117261c4031fb612c65caead07552de59782d8a0e3c8733d79f1cd2ef0118e60eaa7 WHIRLPOOL 6d72867eb46659d31703c299973ecb2cb47e566afd910122c37819afacf5333db398812af41f82adfcda7c83000e8a021ba17f99d401b185f08758ee2a4b7ef5
diff --git a/dev-java/snip/files/snip-0.11-build.xml.patch b/dev-java/snip/files/snip-0.11-build.xml.patch
new file mode 100644
index 000000000000..6072b930a414
--- /dev/null
+++ b/dev-java/snip/files/snip-0.11-build.xml.patch
@@ -0,0 +1,13 @@
+*** build.xml 2006-08-29 21:39:13.000000000 +0000
+--- build.xml.patched 2006-08-29 21:40:15.000000000 +0000
+***************
+*** 1,8 ****
+
+ <project default="compile" name="snip">
+
+- <taskdef name="snip" classname="com.martiansoftware.snip.Snip" classpath="build"/>
+-
+ <property name="version" value="0.11" />
+ <property name="jarname" value="snip-${version}.jar"/>
+ <property name="src.java" value="src/java"/>
+--- 1,6 ----
diff --git a/dev-java/snip/metadata.xml b/dev-java/snip/metadata.xml
new file mode 100644
index 000000000000..456daabcdd66
--- /dev/null
+++ b/dev-java/snip/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ &gt;snip&lt; is an Ant task designed to help with the single-sourcing
+ of program documentation. This task extracts snippets of text from files,
+ placing them into properties in the Ant project. These properties can
+ then be used by any other Ant task, and are particularly useful when
+ referenced by &gt;filter&lt;s within the &gt;copy&lt; task.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/snip/snip-0.11.ebuild b/dev-java/snip/snip-0.11.ebuild
new file mode 100644
index 000000000000..5083dfefebd8
--- /dev/null
+++ b/dev-java/snip/snip-0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="an Apache ANT optional task that extracts snippets of code from text files"
+HOMEPAGE="http://www.martiansoftware.com/lab/index.html"
+SRC_URI="http://www.martiansoftware.com/lab/${PN}/${P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEP=">=dev-java/ant-core-1.5.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ rm -v *.jar
+ epatch "${FILESDIR}/${PN}-0.11-build.xml.patch"
+ java-ant_rewrite-classpath
+ eant clean
+}
+
+EANT_GENTOO_CLASSPATH="ant-core"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/java/com
+}