summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-09-06 10:17:25 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-09-06 10:20:20 +0200
commit71cf14faacdb901d25e6b0f099ce55b6925155d3 (patch)
treedff2fa467ac31ed24f384f5ea281fd86818bb66e /dev-java/joda-time
parentdev-java/snakeyaml: add 1.31 (diff)
downloadgentoo-71cf14faacdb901d25e6b0f099ce55b6925155d3.tar.gz
gentoo-71cf14faacdb901d25e6b0f099ce55b6925155d3.tar.bz2
gentoo-71cf14faacdb901d25e6b0f099ce55b6925155d3.zip
dev-java/joda-time: remove unecessary die, use edo
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/joda-time')
-rw-r--r--dev-java/joda-time/joda-time-2.11.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-java/joda-time/joda-time-2.11.0.ebuild b/dev-java/joda-time/joda-time-2.11.0.ebuild
index 316c6321066d..f9c720bebe0a 100644
--- a/dev-java/joda-time/joda-time-2.11.0.ebuild
+++ b/dev-java/joda-time/joda-time-2.11.0.ebuild
@@ -10,7 +10,7 @@ JAVA_PKG_IUSE="doc source test"
MAVEN_ID="joda-time:joda-time:2.11.0"
JAVA_TESTING_FRAMEWORKS="junit"
-inherit java-pkg-2 java-pkg-simple
+inherit edo java-pkg-2 java-pkg-simple
DESCRIPTION="Date and time library to replace JDK date handling"
HOMEPAGE="https://www.joda.org/joda-time/"
@@ -64,7 +64,7 @@ src_compile() {
# Generate the missing "org/joda/time/tz/data/ZoneInfoMap"
# Arguments from https://github.com/JodaOrg/joda-time/blob/v2.10.10/pom.xml#L413-L427
- "$(java-config -J)" \
+ edo "$(java-config -J)" \
-cp ${PN}.jar \
org.joda.time.tz.ZoneInfoCompiler \
-src "${JAVA_SRC_DIR}/org/joda/time/tz/src" \
@@ -79,7 +79,7 @@ src_compile() {
etcetera \
backward
- java-pkg_addres ${PN}.jar "${P}"/src/main/resources || die
+ java-pkg_addres ${PN}.jar "${P}"/src/main/resources
}
src_test() {