summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/cortado
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/cortado')
-rw-r--r--dev-java/cortado/Manifest1
-rw-r--r--dev-java/cortado/cortado-0.6.0.ebuild38
-rw-r--r--dev-java/cortado/metadata.xml22
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/cortado/Manifest b/dev-java/cortado/Manifest
new file mode 100644
index 000000000000..efb146ff3346
--- /dev/null
+++ b/dev-java/cortado/Manifest
@@ -0,0 +1 @@
+DIST cortado-0.6.0.tar.gz 233854 SHA256 37a708bfceba5b7b0b544456bb3857f708c83734dfb3f3f1ababcc602b923e85 SHA512 56113259da05a73f4d4e7aca92d031fa934987ad3607a69b31666c9e452330a95728e7780c45d825ddeb9c0815ace479d7a55df0e68a50e63a76ddf5602c76da WHIRLPOOL 56f92611743f03c7349b9f40360c3f4bd915cb4fc79cf7ef2597c91113b15f0084c24e83fbc0f8967f3560971b1b04cc70751ff42852c4e10322b3f944371a16
diff --git a/dev-java/cortado/cortado-0.6.0.ebuild b/dev-java/cortado/cortado-0.6.0.ebuild
new file mode 100644
index 000000000000..3c61568b356f
--- /dev/null
+++ b/dev-java/cortado/cortado-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Multimedia framework for Java written by Fluendo"
+HOMEPAGE="http://www.theora.org/cortado/"
+SRC_URI="http://downloads.xiph.org/releases/cortado/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+COMMON_DEP=""
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+EANT_BUILD_TARGET=stripped
+
+src_prepare() {
+ echo "#!/bin/sh" > scripts/get-revision
+ echo "echo ${PV}" >> scripts/get-revision
+}
+
+src_install() {
+ java-pkg_newjar output/dist/applet/${PN}-ovt-stripped-${PV}.jar
+ dodoc ChangeLog HACKING NEWS README RELEASE TODO \
+ || die "dodoc failed"
+}
diff --git a/dev-java/cortado/metadata.xml b/dev-java/cortado/metadata.xml
new file mode 100644
index 000000000000..ff5db0ba4080
--- /dev/null
+++ b/dev-java/cortado/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Cortado is an open-source cross-browser and cross-platform video
+ playback solution based upon Java technology. Leveraging the huge
+ installation base of Java it allows web-authors to deliver Ogg Theora
+ content without having to worry about the media playback setup
+ installed on customers' machines. This enables e.g. Wikipedia to
+ deliver Ogg Theora video content embedded into articles to millions of
+ users. Originally developed at Fluendo, Cortado's latest versions are
+ now maintained by Xiph.org. If you're interested in using free media
+ delivery technology, e.g. to avoid the costs adjunctive to non-free
+ technologies like H.264, and want to reach a big potential user base,
+ Cortado may be the solution you've been looking for.
+ </longdescription>
+</pkgmetadata>