summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/byaccj/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/byaccj/files')
-rw-r--r--dev-java/byaccj/files/Makefile99
1 files changed, 99 insertions, 0 deletions
diff --git a/dev-java/byaccj/files/Makefile b/dev-java/byaccj/files/Makefile
new file mode 100644
index 000000000000..c46772a1de1b
--- /dev/null
+++ b/dev-java/byaccj/files/Makefile
@@ -0,0 +1,99 @@
+#################################################
+## Makefile for Byacc/Java
+## Date: 06 Aug 00
+## Author: Bob Jamison
+#################################################
+
+CC = gcc
+CFLAGS = -O
+LDFLAGS = -static
+TAR = tar
+GZIP = gzip
+VERS = byaccj1.15
+JAVA = /usr/java
+ZIP = zip
+
+INC = -I.
+
+OBJ = closure.o \
+ error.o \
+ lalr.o \
+ lr0.o \
+ main.o \
+ mkpar.o \
+ output.o \
+ reader.o \
+ skeleton.o \
+ symtab.o \
+ verbose.o \
+ warshall.o
+
+irix: yacc
+ mv yacc yacc.irix
+linux: yacc
+ mv yacc yacc.linux
+solaris: yacc
+ mv yacc yacc.solaris
+
+all: yacc
+
+dist:
+ ( \
+ cd .. ; \
+ /bin/rm -rf $(VERS) ; \
+ /bin/mkdir -p $(VERS) ; \
+ /bin/mkdir -p dist ; \
+ /bin/cp -r docs $(VERS) ; \
+ /bin/mkdir -p $(VERS)/src ; \
+ /bin/cp src/*.c $(VERS)/src ; \
+ /bin/cp src/*.h $(VERS)/src ; \
+ /bin/cp src/Makefile $(VERS)/src ; \
+ /bin/cp src/Makefile.bcc $(VERS)/src ; \
+ /bin/cp -f src/yacc.irix $(VERS) ; \
+ /bin/cp -f src/yacc.solaris $(VERS) ; \
+ /bin/cp -f src/yacc.linux $(VERS) ; \
+ /bin/cp -f src/yacc.exe $(VERS) ; \
+ /bin/cp src/README $(VERS) ; \
+ $(TAR) -cvf - $(VERS) | $(GZIP) > dist/$(VERS).tar.gz ;\
+ $(ZIP) dist/$(VERS).zip $(VERS) \
+ )
+
+SRCS = closure.c \
+ error.c \
+ lalr.c \
+ lr0.c \
+ main.c \
+ mkpar.c \
+ output.c \
+ reader.c \
+ skeleton.c \
+ symtab.c \
+ verbose.c \
+ warshall.c
+
+%.o : %.c
+ $(CC) -c $(CFLAGS) $(INC) $< -o $@
+
+yacc: $(OBJ)
+ $(CC) $(LDFLAGS) -o yacc $(OBJ)
+ @echo "done"
+
+clean:
+ /bin/rm -rf *.o *.obj yacc y.tab.c *.java *.class
+ /bin/rm -rf yacc.linux yacc.irix yacc.solaris yacc.exe
+ (cd .. ; /bin/rm -rf $(VERS) ; /bin/rm -rf dist )
+
+### Dependencies
+closure.o: closure.c defs.h
+error.o: error.c defs.h
+lalr.o: lalr.c defs.h
+lr0.o: lr0.c defs.h
+main.o: main.c defs.h
+mkpar.o: mkpar.c defs.h
+output.o: output.c defs.h
+reader.o: reader.c defs.h
+skeleton.o: skeleton.c defs.h
+symtab.o: symtab.c defs.h
+verbose.o: verbose.c defs.h
+warshall.o: warshall.c defs.h
+