summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2021-04-18 13:05:46 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-19 09:42:04 +0100
commitcd7f790896403e85634d09b9a6d52e3902365314 (patch)
treeebb756d943ae08d99791bc2cc32ed17d8632f112 /dev-haskell
parentwww-client/firefox-bin: bump to v78.10.0 ESR (diff)
downloadgentoo-cd7f790896403e85634d09b9a6d52e3902365314.tar.gz
gentoo-cd7f790896403e85634d09b9a6d52e3902365314.tar.bz2
gentoo-cd7f790896403e85634d09b9a6d52e3902365314.zip
dev-haskell/citeproc: bump up to 0.3.0.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/20431 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/citeproc/Manifest1
-rw-r--r--dev-haskell/citeproc/citeproc-0.3.0.9.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/citeproc/Manifest b/dev-haskell/citeproc/Manifest
index 497936f5b81d..29a544713275 100644
--- a/dev-haskell/citeproc/Manifest
+++ b/dev-haskell/citeproc/Manifest
@@ -1 +1,2 @@
DIST citeproc-0.3.0.1.tar.gz 567617 BLAKE2B 8b6df78401f392d3bc3045fe183b25850328bc9a5b0c0ce9334f6cf14e4451e4a526bd23266846d8a625011b1cf5b1b52fee0a5f7c83ea405769704203da5ce6 SHA512 113f3b5dae2bfce13a4b39ef87ea21f763a897182c7a10eae5e7aabbddbb12b773be6583f51578a92bf078e40b0718a69b908049f700f317bbfb509253dae27b
+DIST citeproc-0.3.0.9.tar.gz 572112 BLAKE2B df1ff046f4356f5feebf3551b3be9807b3bfca6ef927805efeb2ff5133968f1bd0ae14923ec83309ad2b8dd50d674f4506b1f62adc53a78f6afccea7cb6da5fa SHA512 48341417e955f8ee4f6ea5e446e37907ed7b75858418c248504d93496b64147d67d7ba5e35ca9033a528982a7650d3013574f5e8686acc085f267e3d6a44b93f
diff --git a/dev-haskell/citeproc/citeproc-0.3.0.9.ebuild b/dev-haskell/citeproc/citeproc-0.3.0.9.ebuild
new file mode 100644
index 000000000000..ee9b06f64280
--- /dev/null
+++ b/dev-haskell/citeproc/citeproc-0.3.0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generates citations and bibliography from CSL styles"
+HOMEPAGE="https://hackage.haskell.org/package/citeproc"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable icu"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/base-compat-0.10:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ >=dev-haskell/pandoc-types-1.22:=[profile?] <dev-haskell/pandoc-types-1.23:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/uniplate:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/xml-conduit:=[profile?]
+ >=dev-lang/ghc-8.6.5:=
+ executable? ( dev-haskell/aeson-pretty:=[profile?] )
+ icu? ( dev-haskell/text-icu:=[profile?] )
+ !icu? ( >=dev-haskell/rfc5051-0.2:=[profile?] <dev-haskell/rfc5051-0.3:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( >=dev-haskell/diff-0.4
+ dev-haskell/mtl
+ dev-haskell/timeit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag icu icu)
+}