summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:55 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:10 +0100
commit43333c692ba12c69013563361029c0b6bdd4555c (patch)
tree6b88248005b63a14d0dcc810ae6c7bdb89148b3a /dev-haskell/tasty-expected-failure
parentdev-haskell/tar: Hackage revision bump (diff)
downloadgentoo-43333c692ba12c69013563361029c0b6bdd4555c.tar.gz
gentoo-43333c692ba12c69013563361029c0b6bdd4555c.tar.bz2
gentoo-43333c692ba12c69013563361029c0b6bdd4555c.zip
dev-haskell/tasty-expected-failure: add 0.12.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tasty-expected-failure')
-rw-r--r--dev-haskell/tasty-expected-failure/Manifest1
-rw-r--r--dev-haskell/tasty-expected-failure/metadata.xml21
-rw-r--r--dev-haskell/tasty-expected-failure/tasty-expected-failure-0.12.3.ebuild40
3 files changed, 45 insertions, 17 deletions
diff --git a/dev-haskell/tasty-expected-failure/Manifest b/dev-haskell/tasty-expected-failure/Manifest
index 68cb8ad5cc9f..e2030edfda58 100644
--- a/dev-haskell/tasty-expected-failure/Manifest
+++ b/dev-haskell/tasty-expected-failure/Manifest
@@ -1 +1,2 @@
DIST tasty-expected-failure-0.11.1.2.tar.gz 3781 BLAKE2B 04101b477457747abbf1a90fed80ab8692e3f771f27fae8310c0451839b38efadf1751ae302a1bac0f020e01533030563c45a2c0d75b03f9cda88ee23d1d8e12 SHA512 31f89d64a1f700a2563b291d287f559e023b0b1059cf5ad35eb9a8b2d4a7d90b2ffced828017b3e86d7ece0b125787f7512e9f4745c75d38bbc688e09031aae5
+DIST tasty-expected-failure-0.12.3.tar.gz 6016 BLAKE2B 2e3b61686aa45c0bdcc593e77a6fed358f526aac5e0abd93b6894a6ab64637ec7ed0e0b94cd979ba8cbe4aaa3d41b80eb748c0cb3eccdd5f8e096055acac9c20 SHA512 38a38a6b918355b341ac52fbbd63312fbc44f2071785401dc667bb50b030e8c1963c5eb8f890c36daa0987d2fb4748effa543076429e0c8dea58f2fb0bf29f0c
diff --git a/dev-haskell/tasty-expected-failure/metadata.xml b/dev-haskell/tasty-expected-failure/metadata.xml
index 3a4f55351f26..ba8a08351743 100644
--- a/dev-haskell/tasty-expected-failure/metadata.xml
+++ b/dev-haskell/tasty-expected-failure/metadata.xml
@@ -5,21 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- With the function 'Test.Tasty.ExpectedFailure.expectFail' in the provided module
- "Test.Tasty.ExpectedFailure", you can mark that you expect test cases to fail,
- and not to pass.
-
- This can for example be used for test-driven development: Create the tests,
- mark them with 'Test.Tasty.ExpectedFailure.expectFail', and you can still push
- to the main branch, without your continuous integration branch failing.
-
- Once someone implements the feature or fixes the bug (maybe unknowingly), the
- test suite will tell him so, due to the now unexpectedly passing test, and he
- can remove the 'Test.Tasty.ExpectedFailure.expectFail' marker.
-
- The module also provides 'Test.Tasty.ExpectedFailure.ignoreTest' to avoid
- running a test. Both funtions are implemented via the more general
- 'Test.Tasty.ExpectedFailure.warpTest', which is also provided.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">tasty-expected-failure</remote-id>
+ <remote-id type="github">nomeata/tasty-expected-failure</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/tasty-expected-failure/tasty-expected-failure-0.12.3.ebuild b/dev-haskell/tasty-expected-failure/tasty-expected-failure-0.12.3.ebuild
new file mode 100644
index 000000000000..fb62f9a5e2d8
--- /dev/null
+++ b/dev-haskell/tasty-expected-failure/tasty-expected-failure-0.12.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Mark tasty tests as failure expected"
+HOMEPAGE="https://github.com/nomeata/tasty-expected-failure"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/tasty-0.11:=[profile?]
+ <dev-haskell/unbounded-delays-0.2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/hedgehog
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hedgehog
+ dev-haskell/tasty-hunit
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}