summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/snap-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/snap-core')
-rw-r--r--dev-haskell/snap-core/Manifest1
-rw-r--r--dev-haskell/snap-core/metadata.xml44
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.7.2.ebuild52
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-haskell/snap-core/Manifest b/dev-haskell/snap-core/Manifest
new file mode 100644
index 000000000000..1952e064d5b8
--- /dev/null
+++ b/dev-haskell/snap-core/Manifest
@@ -0,0 +1 @@
+DIST snap-core-0.9.7.2.tar.gz 91604 SHA256 526a8ebb758c8da5e966a37449fdb072af333275c1b7726ab6317ac93875f651 SHA512 b07e69a636d148d7f9ce107fd056e92aef8de7dcb7a422e6f4fa69db84abf46caae635bca9b5d6d7e25f597449b9f6dcb082b3c01119c7c56f5c296950bad21b WHIRLPOOL 36ee6a2d118218b839b7c45514423ca09a1923be31e62d0fb2c0e16a2ece6429da2b71b3629c08161c487f63d2737e98d517f904795c7524ee5a4fc6cc73038f
diff --git a/dev-haskell/snap-core/metadata.xml b/dev-haskell/snap-core/metadata.xml
new file mode 100644
index 000000000000..8c382561191a
--- /dev/null
+++ b/dev-haskell/snap-core/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name='portable'>No non-haskell unportable code.</flag>
+ </use>
+ <longdescription>
+ Snap is a simple and fast web development framework and server written in
+ Haskell. For more information or to download the latest version, you can
+ visit the Snap project website at &lt;http://snapframework.com/&gt;.
+
+ This library contains the core definitions and types for the Snap framework,
+ including:
+
+ 1. Primitive types and functions for HTTP (requests, responses, cookies,
+ post/query parameters, etc)
+
+ 2. Type aliases and helper functions for Iteratee I/O
+
+ 3. A monad for programming web handlers called \&quot;Snap\&quot;, inspired by
+ happstack&#39;s (&lt;http://happstack.com/index.html&gt;), which allows:
+
+ * Stateful access to the HTTP request and response objects
+
+ * Monadic failure (i.e. MonadPlus/Alternative instances) for declining
+ to handle requests and chaining handlers together
+
+ * Early termination of the computation if you know early what you want
+ to return and want to prevent further monadic processing
+
+ /Quick start/: The &#39;Snap&#39; monad and HTTP definitions are in &quot;Snap.Core&quot;,
+ some iteratee utilities are in &quot;Snap.Iteratee&quot;.
+
+ Higher-level facilities for building web applications (like user/session
+ management, component interfaces, data modeling, etc.) are planned but not
+ yet implemented, so this release will mostly be of interest for those who:
+
+ * need a fast and minimal HTTP API at roughly the same level of abstraction
+ as Java servlets, or
+
+ * are interested in contributing to the Snap Framework project.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/snap-core/snap-core-0.9.7.2.ebuild b/dev-haskell/snap-core/snap-core-0.9.7.2.ebuild
new file mode 100644
index 000000000000..785a10c18983
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-0.9.7.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/attoparsec-enumerator-0.3:=[profile?] <dev-haskell/attoparsec-enumerator-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-builder-enumerator-0.2:=[profile?] <dev-haskell/blaze-builder-enumerator-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.3:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/enumerator-0.4.15:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.2.1:=[profile?] <dev-haskell/monadcatchio-transformers-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/zlib-enum-0.2.1:=[profile?] <dev-haskell/zlib-enum-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.2:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+ portable? ( >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?] )
+ !portable? ( >=dev-haskell/bytestring-mmap-0.2.2:=[profile?] <dev-haskell/bytestring-mmap-0.3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}