summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 13:43:25 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:25 +0000
commit254f2d07454e3c81e5c1c300d43cc8db2ca10817 (patch)
tree67df1959d533d10f82e678e81ac09b6238f32b1f /dev-haskell/lpeg
parentdev-haskell/logging-facade: keyword 0.3.0 for ~ppc64 (diff)
downloadgentoo-254f2d07454e3c81e5c1c300d43cc8db2ca10817.tar.gz
gentoo-254f2d07454e3c81e5c1c300d43cc8db2ca10817.tar.bz2
gentoo-254f2d07454e3c81e5c1c300d43cc8db2ca10817.zip
dev-haskell/lpeg: new package, add 1.0.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/lpeg')
-rw-r--r--dev-haskell/lpeg/Manifest1
-rw-r--r--dev-haskell/lpeg/lpeg-1.0.3.ebuild32
-rw-r--r--dev-haskell/lpeg/metadata.xml14
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/lpeg/Manifest b/dev-haskell/lpeg/Manifest
new file mode 100644
index 000000000000..d4e67ba27c55
--- /dev/null
+++ b/dev-haskell/lpeg/Manifest
@@ -0,0 +1 @@
+DIST lpeg-1.0.3.tar.gz 40092 BLAKE2B fa7abf62be859a15b66aacefb8b170488a59a48cf8d209653bb274327af5ad145a047a0e654b37819045eb594389d405813dbe2c9956f91461bf29e4f3ad99d1 SHA512 636a983054576487af8663d627ea16b57894eca18c92a5994abcdeec11acaa1b5d7bb0da1eae0a1a175c75fad44c93a78c5a5e6e7ce25ddac67f5b376559fbdc
diff --git a/dev-haskell/lpeg/lpeg-1.0.3.ebuild b/dev-haskell/lpeg/lpeg-1.0.3.ebuild
new file mode 100644
index 000000000000..c2faa9ca52db
--- /dev/null
+++ b/dev-haskell/lpeg/lpeg-1.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="LPeg - Parsing Expression Grammars For Lua"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="rely-on-shared-lpeg-library"
+
+RDEPEND=">=dev-haskell/lua-2.1:=[profile?] <dev-haskell/lua-2.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag rely-on-shared-lpeg-library rely-on-shared-lpeg-library)
+}
diff --git a/dev-haskell/lpeg/metadata.xml b/dev-haskell/lpeg/metadata.xml
new file mode 100644
index 000000000000..604a49e01944
--- /dev/null
+++ b/dev-haskell/lpeg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="rely-on-shared-lpeg-library">Do not build lpeg from source, but trust that lpeg is
+made available in other ways, e.g., through a
+system-wide installation. The loader will be replaced
+with a placeholder function that only emits a message.</flag>
+ </use>
+</pkgmetadata>