summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:56 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:26 +0100
commitbfaff7af083789f146de267a2fa69e5aad53464d (patch)
treec4a8d5a4c25fdeaf22badd5f0b91a59589b1106e /dev-haskell/cryptohash-sha256
parentdev-haskell/cryptohash-sha1: Migrate to CABAL_CHDEPS (diff)
downloadgentoo-bfaff7af083789f146de267a2fa69e5aad53464d.tar.gz
gentoo-bfaff7af083789f146de267a2fa69e5aad53464d.tar.bz2
gentoo-bfaff7af083789f146de267a2fa69e5aad53464d.zip
dev-haskell/cryptohash-sha256: add 0.11.102.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/cryptohash-sha256')
-rw-r--r--dev-haskell/cryptohash-sha256/Manifest2
-rw-r--r--dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild58
-rw-r--r--dev-haskell/cryptohash-sha256/metadata.xml19
3 files changed, 64 insertions, 15 deletions
diff --git a/dev-haskell/cryptohash-sha256/Manifest b/dev-haskell/cryptohash-sha256/Manifest
index 2f3fa9b976b1..0f862c30cc24 100644
--- a/dev-haskell/cryptohash-sha256/Manifest
+++ b/dev-haskell/cryptohash-sha256/Manifest
@@ -1 +1,3 @@
DIST cryptohash-sha256-0.11.101.0.tar.gz 14996 BLAKE2B 9caccc3eea4ad25c6ebbdd507771d86264a853f282d03399917b42a5311dcad0501bd0b4ea6fa00d039f67bcea3f81c116b9ec016d65cb2ed6f086b0448894c0 SHA512 c755f1354fb5f1d6cfb54f73e39692392517954118d98b39ac4be7460e75a9ddc91ad641fed0f17e5fa33b62b7b0734af66526ea757e00716832572bb383c612
+DIST cryptohash-sha256-0.11.102.1-rev3.cabal 5457 BLAKE2B ed2c47aaed406a62bff372abf9f7768a7a40dc3a84d9ccd16c50dc5a0a05957f6885a87619d463ef546bd804b406f9a632963ec60818efc12582dac6edca46af SHA512 b1a3807ce57eb3f24b343a903b6849c08e4de90d33f77504723b8c5b18138ab527a953fee3ff06d6a55e4af1360494289149e199182422a9734b209bfe9f37c1
+DIST cryptohash-sha256-0.11.102.1.tar.gz 15707 BLAKE2B 16f7b8c39df3eac22af30ea14c98b0a6ef8056118dbc8236dd8951f7d35e32ba07fbf5f318a0896b0ef70ff1459f03937df4ef30b0247835e7550fedaf42386e SHA512 fb4432050ab1236fc913ba50949ee52a117b0d74509b58868e8ade69bfc6e89e1379dfea48afc76d8527d4fdbaee9dd1d2dcea4530ba95a42441491df005e78c
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild
new file mode 100644
index 000000000000..0e9b0ff14db7
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: exe:executable,+use-cbits
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-256 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha256"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+CABAL_CHBINS=(
+ 'sha256sum' 'cryptohash-sha256sum'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+ executable? (
+ || (
+ ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2 )
+ =dev-haskell/base16-bytestring-1.0*
+ )
+ dev-haskell/base16-bytestring:=[profile?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.6
+ =dev-haskell/tasty-hunit-0.10*
+ =dev-haskell/tasty-quickcheck-0.10*
+ || (
+ ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2 )
+ =dev-haskell/base16-bytestring-1.0*
+ )
+ )
+"
+
+src_configure() {
+ local conf_flags=(
+ $(cabal_flag executable exe)
+ --flag=use-cbits
+ )
+
+ haskell-cabal_src_configure "${conf_flags[@]}"
+}
diff --git a/dev-haskell/cryptohash-sha256/metadata.xml b/dev-haskell/cryptohash-sha256/metadata.xml
index eaac8fbe800a..0abeaaf769d6 100644
--- a/dev-haskell/cryptohash-sha256/metadata.xml
+++ b/dev-haskell/cryptohash-sha256/metadata.xml
@@ -5,22 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A practical incremental and one-pass, pure API to the
- &lt;https://en.wikipedia.org/wiki/SHA-2 SHA-256 hash algorithm&gt;
- with performance close to the fastest implementations available in other languages.
-
- The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
-
- NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ has been
- deprecated and so this package continues to satisfy the need for a lightweight package
- providing the SHA256 hash algorithm without any dependencies on packages other than
- @base@ and @bytestring@.
-
- Consequently, this package can be used as a drop-in replacement for @cryptohash@'s
- "Crypto.Hash.SHA256" module, though with a clearly smaller footprint.
- </longdescription>
+ <use>
+ <flag name="executable">Build the cryptohash-sha256sum executable</flag>
+ </use>
<upstream>
+ <remote-id type="hackage">cryptohash-sha256</remote-id>
<remote-id type="github">hvr/cryptohash-sha256</remote-id>
</upstream>
</pkgmetadata>