summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-16 14:55:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-16 14:55:12 -0500
commitb3a2b5d432d8c506dbc179673f2921bc0ede9d01 (patch)
treefdfd728e43bd08b270e21417bf058f1e3c726051 /dev-go
parentdev-lang/luajit: Stabilize 2.1.1716656478 x86, #936162 (diff)
downloadgentoo-b3a2b5d432d8c506dbc179673f2921bc0ede9d01.tar.gz
gentoo-b3a2b5d432d8c506dbc179673f2921bc0ede9d01.tar.bz2
gentoo-b3a2b5d432d8c506dbc179673f2921bc0ede9d01.zip
dev-go/go-dep-tarball: add 0.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-dep-tarball/files/go-dep-tarball-0.160
-rw-r--r--dev-go/go-dep-tarball/go-dep-tarball-0.1.ebuild17
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-go/go-dep-tarball/files/go-dep-tarball-0.1 b/dev-go/go-dep-tarball/files/go-dep-tarball-0.1
new file mode 100644
index 000000000000..50afdd5f068d
--- /dev/null
+++ b/dev-go/go-dep-tarball/files/go-dep-tarball-0.1
@@ -0,0 +1,60 @@
+#!/bin/bash
+# Copyright (c) 2024, William Hubbs
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+# 3. Neither the name of the copyright holder nor the names of its
+# contributors may be used to endorse or promote products derived from
+# this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+set -e
+shopt -s lastpipe
+
+if [[ -z $1 ]]; then
+printf "%s\n" "no tarball name specified" >&2
+exit 1
+fi
+
+if [[ ! -f go.mod ]]; then
+printf "%s %s\n" "${PWD}" "does not contain a go project" >&2
+exit 1
+fi
+
+work=$(mktemp -d -p '' dep-tarball-XXXXXX)
+export GOMODCACHE="${work}"/go-mod
+go mod download -modcacherw
+mapfile -t mod_paths < <(find . -mindepth 2 -name go.mod -print)
+for p in "${mod_paths[@]}"; do
+ printf "entering %s\n" "${p%/go.mod}"
+ pushd "${p%/go.mod}" > /dev/null
+ go mod download -modcacherw
+ popd > /dev/null
+done
+find "${GOMODCACHE}/cache/download" -type f -name '*.zip' -delete
+(
+cd "${work}"
+XZ_OPT='-T0 -9' \
+tar --owner 0 --group 0 --posix -acf "${1}"-deps.tar.xz go-mod
+rm -fr go-mod
+)
+mv "${work}"/*xz .
+rmdir "${work}"
diff --git a/dev-go/go-dep-tarball/go-dep-tarball-0.1.ebuild b/dev-go/go-dep-tarball/go-dep-tarball-0.1.ebuild
new file mode 100644
index 000000000000..32fc7db0556d
--- /dev/null
+++ b/dev-go/go-dep-tarball/go-dep-tarball-0.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="script to package go dependencies"
+HOMEPAGE=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+S="${WORKDIR}"
+
+src_install() {
+ newbin "${FILESDIR}/go-dep-tarball-${PV}" go-dep-tarball
+}