summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-02 21:08:22 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-02 21:08:22 +0300
commitb50599bf3fefb07257092fb0e4959e025a677e53 (patch)
tree35aa1569a8690986408c47d4f657808a6ae7f282 /dev-go/sarama/sarama-1.4.3.ebuild
parentapp-emulation/ganeti-htools: remove last rited package (diff)
downloadgentoo-b50599bf3fefb07257092fb0e4959e025a677e53.tar.gz
gentoo-b50599bf3fefb07257092fb0e4959e025a677e53.tar.bz2
gentoo-b50599bf3fefb07257092fb0e4959e025a677e53.zip
dev-go/sarama: remove last rited package
Closes: https://bugs.gentoo.org/631696 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-go/sarama/sarama-1.4.3.ebuild')
-rw-r--r--dev-go/sarama/sarama-1.4.3.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-go/sarama/sarama-1.4.3.ebuild b/dev-go/sarama/sarama-1.4.3.ebuild
deleted file mode 100644
index f31a6e76af8f..000000000000
--- a/dev-go/sarama/sarama-1.4.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGO_SRC=github.com/Shopify/${PN}
-EGO_PN=${EGO_SRC}/...
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64"
- SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-inherit golang-build
-
-DESCRIPTION="Sarama is a Go library for Apache Kafka"
-HOMEPAGE="https://github.com/Shopify/sarama"
-LICENSE="MIT"
-SLOT="0/${PV}"
-IUSE="test"
-DEPEND="dev-go/go-eapache-queue
- dev-go/go-resiliency
- dev-go/go-snappy
- test? ( dev-go/go-spew )"
-RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
-src_prepare() {
- # avoid toxiproxy dependency
- rm src/${EGO_SRC}/functional*_test.go || die
-}
-
-src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
- golang-build_src_install
- rm bin/http_server || die
- dobin bin/*
-}