summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-04-21 22:03:32 -0400
committerFlorian Schmaus <flow@gentoo.org>2024-05-03 22:57:34 +0200
commit957c2bb065b3f4f80ac744074195680abac3fa57 (patch)
treeb98f59e94f76f4b1f624d74698d6c87e367850f7 /dev-erlang/jose
parentapp-misc/tracker: fix regression from sqlite-3.45.3 behaviour change (diff)
downloadgentoo-957c2bb065b3f4f80ac744074195680abac3fa57.tar.gz
gentoo-957c2bb065b3f4f80ac744074195680abac3fa57.tar.bz2
gentoo-957c2bb065b3f4f80ac744074195680abac3fa57.zip
dev-erlang/jose: add 1.11.10
- Tests not ran (restricted) - Fix trivial QA warning - Put S below SRC_URI Bug: https://bugs.gentoo.org/927310 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/36350 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-erlang/jose')
-rw-r--r--dev-erlang/jose/Manifest1
-rw-r--r--dev-erlang/jose/jose-1.11.10.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-erlang/jose/Manifest b/dev-erlang/jose/Manifest
index 157a3090b79a..3e9c83994d6e 100644
--- a/dev-erlang/jose/Manifest
+++ b/dev-erlang/jose/Manifest
@@ -1,2 +1,3 @@
+DIST erlang-jose-1.11.10.tar.gz 330654 BLAKE2B e397d233799d42ff4fd2e9c31e7eb921c322506eb30e86caabcb9aae7b6f259a668e4a1027cd5b1fc647c46eaf54e575f6f38d64db0b6bbd0a1911709eccae36 SHA512 cddf868c360126a01727c19ac8bb4de3a0ebba191f84b6907da72666e1d29abaccfa2717527f8ec633c711e84771805b0ec1ad5f5b8f33df16ac2622e4b8e35d
DIST erlang-jose-1.11.2.tar.gz 281313 BLAKE2B 14b7cb9a690fb960c3b2bd90c64ce0d13309abab26250346de5d5ab5d58eab56bcac09f3b91e74bb6c982c33bb557bf4b992c3da62e3c107dc4b3caa175c2feb SHA512 8a9edbda0150b110f1394fb8f4ad57878d2562c6bb1c17938e69b49ff224ed347cb8d325750bae7b61c9cc2ce2c5d089f963e369c8c74f6a2a55cef963f813a5
DIST erlang-jose-1.11.5.tar.gz 327036 BLAKE2B 83bdb9259f8a231bc976ba2b5be1fb39c6fcef3270eb352c6ea4e29857213e809306b210af571ebdb15e7475ceae15b24e9d0508aa405436c3acf0c1304eeec5 SHA512 2d1a293dbe63ce7dc32a07929f30580f47db468e540bc28433971a362feb3b19ef65caf11d74ddd7cd80a5be80e22ab4d0752a9bf248ac60f8f05c69e51ba1a0
diff --git a/dev-erlang/jose/jose-1.11.10.ebuild b/dev-erlang/jose/jose-1.11.10.ebuild
new file mode 100644
index 000000000000..3750bdd09496
--- /dev/null
+++ b/dev-erlang/jose/jose-1.11.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rebar
+
+DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
+HOMEPAGE="https://github.com/potatosalad/erlang-jose"
+SRC_URI="
+ https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz
+ -> erlang-${P}.tar.gz
+"
+S="${WORKDIR}/erlang-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-19.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( ALGORITHMS.md CHANGELOG.md README.md examples/KEY-GENERATION.md )
+
+# TODO: jose has test suite, but it require lots of dependencies. It may not be
+# TODO: urgent, but it would be nice to have those sooner or later.
+RESTRICT=test