summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-24 10:10:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-24 21:37:52 +0300
commit3cd605429af74ba054e53b6f52a2a02d606136da (patch)
tree03909eebc2e5b17833c00b2dbc6d330b6e54e285 /dev-embedded
parentapp-mobilephone/dfu-util: use https:// instead of git:// for cloning (diff)
downloadgentoo-3cd605429af74ba054e53b6f52a2a02d606136da.tar.gz
gentoo-3cd605429af74ba054e53b6f52a2a02d606136da.tar.bz2
gentoo-3cd605429af74ba054e53b6f52a2a02d606136da.zip
dev-embedded/urjtag: use https:// instead of git:// for cloning
git:// is unencrypted and could be used by an attacker (mitm) to insert malicious code, see also [1]. git:// runs on port 9418 which is also less likely open behind a firewall. [1] git-scm.com/book/en/v2/Git-on-the-Server-The-Protocols Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/urjtag/urjtag-2021.03.ebuild6
-rw-r--r--dev-embedded/urjtag/urjtag-9999.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-embedded/urjtag/urjtag-2021.03.ebuild b/dev-embedded/urjtag/urjtag-2021.03.ebuild
index 1b765b94391a..56275fc855ba 100644
--- a/dev-embedded/urjtag/urjtag-2021.03.ebuild
+++ b/dev-embedded/urjtag/urjtag-2021.03.ebuild
@@ -8,16 +8,16 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit python-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.code.sf.net/p/urjtag/git"
+ EGIT_REPO_URI="https://git.code.sf.net/p/urjtag/git"
inherit git-r3 autotools
S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://downloads.sourceforge.net/urjtag/${P}.tar.xz"
+ SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="amd64 ppc sparc x86"
fi
DESCRIPTION="Tool for communicating over JTAG with flash chips, CPUs, and many more"
-HOMEPAGE="https://urjtag.sourceforge.net/"
+HOMEPAGE="https://urjtag.sourceforge.io/"
LICENSE="GPL-2"
SLOT="0"
diff --git a/dev-embedded/urjtag/urjtag-9999.ebuild b/dev-embedded/urjtag/urjtag-9999.ebuild
index d01057522264..60327e2adb4b 100644
--- a/dev-embedded/urjtag/urjtag-9999.ebuild
+++ b/dev-embedded/urjtag/urjtag-9999.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit python-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.code.sf.net/p/urjtag/git"
+ EGIT_REPO_URI="https://git.code.sf.net/p/urjtag/git"
inherit git-r3 autotools
S="${WORKDIR}/${P}/${PN}"
else
@@ -17,7 +17,7 @@ else
fi
DESCRIPTION="Tool for communicating over JTAG with flash chips, CPUs, and many more"
-HOMEPAGE="https://urjtag.sourceforge.net/"
+HOMEPAGE="https://urjtag.sourceforge.io/"
LICENSE="GPL-2"
SLOT="0"