summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-24 13:00:54 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-24 13:01:32 +0200
commit15fc47f25b9526cca2b252d07a9f8b91b2b586fb (patch)
treeca7642e0e7e205ec17086bbf28fdb07091c304b4 /dev-embedded/usbprog
parentdev-texlive/texlive-pictures: Bump pgf dep to 3.0.1. Bug #556004. (diff)
downloadgentoo-15fc47f25b9526cca2b252d07a9f8b91b2b586fb.tar.gz
gentoo-15fc47f25b9526cca2b252d07a9f8b91b2b586fb.tar.bz2
gentoo-15fc47f25b9526cca2b252d07a9f8b91b2b586fb.zip
dev-embedded/usbprog: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-embedded/usbprog')
-rw-r--r--dev-embedded/usbprog/files/usbprog-0.2.0-wx3.0.patch25
-rw-r--r--dev-embedded/usbprog/usbprog-0.2.0-r1.ebuild44
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-embedded/usbprog/files/usbprog-0.2.0-wx3.0.patch b/dev-embedded/usbprog/files/usbprog-0.2.0-wx3.0.patch
new file mode 100644
index 000000000000..bfd47ad89c74
--- /dev/null
+++ b/dev-embedded/usbprog/files/usbprog-0.2.0-wx3.0.patch
@@ -0,0 +1,25 @@
+Description: Fix to build with wxWidgets 3.0
+ This patch should also work with wxWidgets 2.8.
+Author: Olly Betts <olly@survex.com>
+Last-Update: 2014-03-12
+
+--- usbprog-0.2.0.orig/gui/usbprogFrm.cc
++++ usbprog-0.2.0/gui/usbprogFrm.cc
+@@ -296,7 +296,7 @@ void usbprogFrm::CreateGUIControls()
+
+ // file dialog
+ m_fileDialog = new wxFileDialog(m_panel, wxT("Choose a file"),
+- wxT(""), wxT(""), wxT("*.bin"), wxOPEN);
++ wxT(""), wxT(""), wxT("*.bin"), wxFD_OPEN);
+
+ m_topBox->Add(topSizer, wxEXPAND, wxALL, 10);
+
+@@ -670,7 +670,7 @@ void usbprogFrm::enableDisableDebug(wxCo
+ dbg->setFileHandle(NULL);
+ } else {
+ wxFileDialog fdg(m_panel, wxT("Choose a file"),
+- wxT(""), wxT(""), wxT("*.log"), wxSAVE);
++ wxT(""), wxT(""), wxT("*.log"), wxFD_SAVE);
+ if (fdg.ShowModal() != wxID_OK)
+ dbg->setFileHandle(stderr);
+ else {
diff --git a/dev-embedded/usbprog/usbprog-0.2.0-r1.ebuild b/dev-embedded/usbprog/usbprog-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..2957a339987c
--- /dev/null
+++ b/dev-embedded/usbprog/usbprog-0.2.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER="3.0"
+
+inherit eutils wxwidgets
+
+DESCRIPTION="flashtool for the multi purpose programming adapter usbprog"
+HOMEPAGE="http://www.embedded-projects.net/index.php?page_id=215"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs X"
+
+RDEPEND="
+ X? ( x11-libs/wxGTK:${WX_GTK_VER} )
+ >=dev-libs/libxml2-2.0.0
+ net-misc/curl
+ virtual/libusb:0
+ sys-libs/readline
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wx3.0.patch
+}
+
+src_configure() {
+ use X && need-wxwidgets unicode
+ econf \
+ $(use_enable X gui) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}