summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-01-25 17:55:29 -0800
committerZac Medico <zmedico@gentoo.org>2016-01-25 17:57:36 -0800
commit7ffd92f12385548bb62e749cf7d79a7e7f68f32f (patch)
tree943e1c8618f2db44a887e47373a5337d51617edd /dev-db
parentdev-util/astyle: Take ownership of package (diff)
downloadgentoo-7ffd92f12385548bb62e749cf7d79a7e7f68f32f.tar.gz
gentoo-7ffd92f12385548bb62e749cf7d79a7e7f68f32f.tar.bz2
gentoo-7ffd92f12385548bb62e749cf7d79a7e7f68f32f.zip
dev-db/redis: version bump to 3.0.6
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/Manifest1
-rw-r--r--dev-db/redis/redis-3.0.6.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/dev-db/redis/Manifest b/dev-db/redis/Manifest
index 7b275746f8f2..f1cbf2b74c77 100644
--- a/dev-db/redis/Manifest
+++ b/dev-db/redis/Manifest
@@ -3,3 +3,4 @@ DIST redis-2.8.21.tar.gz 1260030 SHA256 3da371693bb54c22da04d86cab1b871072c8d19b
DIST redis-2.8.23.tar.gz 1265194 SHA256 f3c79778f478a01237035b67edaaa19332e5624dfa849d66815a4328d3e95ace SHA512 ab27d5f4da3a1a03f513dd6e731517b59c8857961599651f51ced29138c907e3968390d2a473e26690d8ada6808cff1b948999ed171e9826cad8449031fc39ce WHIRLPOOL e18e5caf086c41743642d817b69ce7d923505ebb90373c7b8ccac5990bfa1972e264292e3d78310e84378b958c0ab818d208349763ab43eb9cfc05030755a6f5
DIST redis-3.0.4.tar.gz 1364993 SHA256 a35e90ad581925134aa0fc92e969cc825f5cdee8e13c36a87d4d6995316112cf SHA512 7d8d681222892c759e7c3809203522a96a547457e0ff123cca296bac911395c7d8c1ded06331ae5cb487b87d0adcbaa02aa12c2dd724196a7b86111e236b023a WHIRLPOOL e12f7751e3e25068a25c02990d0e8416cedc152f66b5e9e1e47ae91f10a0d543b96ad456a4eb7fe16cb92ed46a0cc2fee65954207b354b9c211f425191a6c388
DIST redis-3.0.5.tar.gz 1366160 SHA256 4c176826eee909fbdc63db1c15adc22aab42d758043829e556f4331e6a5bd480 SHA512 f44e2bcf2f4910da9f9d9e31ec542d5816ec0ba4329efe3e5053cc0176a5a8557d905f23bd3fd37e8a6e674eaf12804613718f63cb2ca1eac2b4f9c6082acab6 WHIRLPOOL 5b58ca02af6be7768c89e9307d668081cc161f9a200a1db40f0216b6c564cb67c8230d420024c12fb5f2397cedb8979a62ad01a61d526030018171a69a22e19d
+DIST redis-3.0.6.tar.gz 1372648 SHA256 6f1e1523194558480c3782d84d88c2decf08a8e4b930c56d4df038e565b75624 SHA512 cb29b2ed6db4a77ffafc27a94deb71b73332f4e05b63957ac870532a634d7aaf1df4225aec8bc3011322b6df35a7f0e7c3f3bb070e29aabd3dabdb5cfbb681d4 WHIRLPOOL ce0de5aa188d8c631456ea5bf6346357676eb8c5f0f6bc69a704f7d35559ec6a4f5c0e583e321f546fc91c6c51d0331065d64be601864e033ce7d47da002d71b
diff --git a/dev-db/redis/redis-3.0.6.ebuild b/dev-db/redis/redis-3.0.6.ebuild
new file mode 100644
index 000000000000..7e5e67b1c6da
--- /dev/null
+++ b/dev-db/redis/redis-3.0.6.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic systemd toolchain-funcs user
+
+DESCRIPTION="A persistent caching system, key-value and data structures database"
+HOMEPAGE="http://redis.io/"
+SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+jemalloc tcmalloc test"
+SLOT="0"
+
+RDEPEND=">=dev-lang/lua-5.1:*
+ tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="virtual/pkgconfig
+ >=sys-devel/autoconf-2.63
+ test? ( dev-lang/tcl:0= )
+ ${RDEPEND}"
+REQUIRED_USE="?? ( tcmalloc jemalloc )"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+pkg_setup() {
+ enewgroup redis 75
+ enewuser redis 75 -1 /var/lib/redis redis
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.8.3-shared.patch
+ epatch "${FILESDIR}"/${PN}-2.8.17-config.patch
+ epatch "${FILESDIR}"/${PN}-3.0.0-sharedlua.patch
+
+ # Copy lua modules into build dir
+ cp "${S}"/deps/lua/src/{fpconv,lua_bit,lua_cjson,lua_cmsgpack,lua_struct,strbuf}.c "${S}"/src || die
+ cp "${S}"/deps/lua/src/{fpconv,strbuf}.h "${S}"/src || die
+ # Append cflag for lua_cjson
+ # https://github.com/antirez/redis/commit/4fdcd213#diff-3ba529ae517f6b57803af0502f52a40bL61
+ append-cflags "-DENABLE_CJSON_GLOBAL"
+
+ # now we will rewrite present Makefiles
+ local makefiles=""
+ for MKF in $(find -name 'Makefile' | cut -b 3-); do
+ mv "${MKF}" "${MKF}.in"
+ sed -i -e 's:$(CC):@CC@:g' \
+ -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
+ -e 's: $(DEBUG)::g' \
+ -e 's:$(OBJARCH)::g' \
+ -e 's:ARCH:TARCH:g' \
+ -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
+ "${MKF}.in" \
+ || die "Sed failed for ${MKF}"
+ makefiles+=" ${MKF}"
+ done
+ # autodetection of compiler and settings; generates the modified Makefiles
+ cp "${FILESDIR}"/configure.ac-2.2 configure.ac
+ sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
+ configure.ac || die "Sed failed for configure.ac"
+ eautoconf
+}
+
+src_configure() {
+ econf
+
+ # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
+ # also, don't define ANSI/c99 for lua twice
+ sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+
+ local myconf=""
+
+ if use tcmalloc ; then
+ myconf="${myconf} USE_TCMALLOC=yes"
+ elif use jemalloc ; then
+ myconf="${myconf} JEMALLOC_SHARED=yes"
+ else
+ myconf="${myconf} MALLOC=yes"
+ fi
+
+ emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}"
+}
+
+src_install() {
+ insinto /etc/
+ doins redis.conf sentinel.conf
+ use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
+ fperms 0644 /etc/{redis,sentinel}.conf
+
+ newconfd "${FILESDIR}/redis.confd" redis
+ newinitd "${FILESDIR}/redis.initd-4" redis
+
+ systemd_newunit "${FILESDIR}/redis.service-2" redis.service
+ systemd_newtmpfilesd "${FILESDIR}/redis.tmpfiles" redis.conf
+
+ dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
+
+ dobin src/redis-cli
+ dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
+ fperms 0750 /usr/sbin/redis-benchmark
+ dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
+
+ if use prefix; then
+ diropts -m0750
+ else
+ diropts -m0750 -o redis -g redis
+ fi
+ keepdir /var/{log,lib}/redis
+}