summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-23 10:49:07 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-23 10:50:50 -0500
commit120735a30fd5fa305232a9af36da1563013d7095 (patch)
tree1daacb80ebdef5dc44d57297e8946ea04622d69e /dev-db
parentgames-engines/devilutionx: Can be built with ninja again (diff)
downloadgentoo-120735a30fd5fa305232a9af36da1563013d7095.tar.gz
gentoo-120735a30fd5fa305232a9af36da1563013d7095.tar.bz2
gentoo-120735a30fd5fa305232a9af36da1563013d7095.zip
dev-db/etcd: 3.4.5 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-3.4.5.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index 05c877441b5f..0782ccedd7f7 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -3,3 +3,4 @@ DIST etcd-3.3.18.tar.gz 6508732 BLAKE2B cce52ac9fa005388bafacf3d0bf049f3930de12d
DIST etcd-3.3.19.tar.gz 6509566 BLAKE2B 0037858daa134e63c6629defe099cc772b758e220a093e719b2d41c2e519a2c2d923d26e8635fb1f7cabe2ec0a0250236293c838d9c34d1745673211dc4f526c SHA512 9f21692466bcb240bac042f4e7ee6f4575c05312542827c7349257b87c9d4a1a625b200fcbb0852c86c192624cd02e9a8d80caa194d25d4b63aa5e33b100eac1
DIST etcd-3.4.3.tar.gz 8941589 BLAKE2B 127e4a8dd9495686ffc43099c3002e0e3c00ab661bce917ac298f69351e1226dff0efcaf9277c1e46449abafef965af8f612a127e1e30c381545073232a2ff50 SHA512 0bc1e857b707be1d348f5ab58a330d259dd30338c28580751142f643b2a081d1fe42a8859fa9463a734ff27f51929dc89f933f044b89d6e549a348add034d752
DIST etcd-3.4.4.tar.gz 8940682 BLAKE2B c165fbb61d87d4a42261742bf302e6a04daa67e6ebea6f12314b77a9a12afd0e6b02e642b827e8b14fa77eedd207fe32c047f19f0487f54aba1e0db6774673f2 SHA512 81de69c422c58c73df8812127f29e49e1d81dacf47e26fe4b8a332b6b19f0242086c5e3b52fdbbbf08d91abe6213400887dc72e837effeec73a182a8caca9d20
+DIST etcd-3.4.5.tar.gz 8943585 BLAKE2B 6df1538ec1e65c6f1a7fc41c0ceb29ca126efe797c8e6e029dfd45cdfeadacd322a46e18f627cac6defd78d8a17ddf09b5a0918fb454bfbafd450084de972c5a SHA512 cd8845433e208cbe1cf0e0a001ee503d42b73f44ac0e0578d9ee8692f95262929c0cec3a2622f9cd3ea8d393a136de47a7e0d0875b4e0cd9d8eeddd45ca3bea5
diff --git a/dev-db/etcd/etcd-3.4.5.ebuild b/dev-db/etcd/etcd-3.4.5.ebuild
new file mode 100644
index 000000000000..8848dd8b39f6
--- /dev/null
+++ b/dev-db/etcd/etcd-3.4.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module systemd
+GIT_COMMIT=e784ba73c
+MY_PV="${PV/_rc/-rc.}"
+
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/etcd-io/etcd"
+SRC_URI="https://github.com/etcd-io/etcd/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +server"
+
+COMMON_DEPEND="server? (
+ acct-group/etcd
+ acct-user/etcd
+ )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ !dev-db/etcdctl"
+
+src_prepare() {
+ default
+ sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
+ -i "${S}"/build || die
+ sed -e 's:\(for p in \)shellcheck :\1 :' \
+ -e 's:^ gofmt \\$:\\:' \
+ -e 's:^ govet \\$:\\:' \
+ -e 's:^ govet_shadow \\$:\\:' \
+ -i "${S}"/test || die
+ # missing ... in args forwarded to print-like function
+ sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
+ -i "${S}"/raft/logger.go || die
+
+ sed -e 's:TestGetDefaultInterface(:_\0:' \
+ -e 's:TestGetDefaultHost(:_\0:' \
+ -i "${S}"/pkg/netutil/routes_linux_test.go || die
+}
+
+src_compile() {
+ GO_BUILD_FLAGS=-v ./build || die
+}
+
+src_install() {
+ dobin bin/etcdctl
+ use doc && dodoc -r Documentation
+ if use server; then
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/etcd
+ dodoc README.md
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 0700 /var/lib/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+ fi
+}
+
+src_test() {
+ ./test || die
+}