summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/db-je
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/db-je')
-rw-r--r--dev-db/db-je/Manifest1
-rw-r--r--dev-db/db-je/db-je-3.3.75.ebuild39
-rw-r--r--dev-db/db-je/files/db-je-3.3.75-optional-test.patch45
-rw-r--r--dev-db/db-je/metadata.xml10
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-db/db-je/Manifest b/dev-db/db-je/Manifest
new file mode 100644
index 000000000000..c563a83e11d2
--- /dev/null
+++ b/dev-db/db-je/Manifest
@@ -0,0 +1 @@
+DIST je-3.3.75.tar.gz 5179709 SHA256 98bb5b374eac336329e4bb87f537355ba5128e697f2bfea5904eba46a5f1ee08 SHA512 e28648459a3a7dcf98e8865e6859544c656c3b58688b244df568cc8c006a74dda79aadfbfb279e099c1376914cca064734da490998a864c1bd2cc3209bc64ae4 WHIRLPOOL a86747a5a30444847e666fd82bd397ead06b4597200b82ce7e88301e6e8531faf267b1cebf2850bfc072916a3a1b903fe35012466a44a5c6bd5311cbce43455b
diff --git a/dev-db/db-je/db-je-3.3.75.ebuild b/dev-db/db-je/db-je-3.3.75.ebuild
new file mode 100644
index 000000000000..2fa03b917ce8
--- /dev/null
+++ b/dev-db/db-je/db-je-3.3.75.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Berkeley DB JE is a high performance, transactional storage engine written entirely in Java"
+HOMEPAGE="http://www.oracle.com/database/berkeley-db/je/index.html"
+SRC_URI="http://download.oracle.com/berkeley-db/${P/db-/}.tar.gz"
+
+LICENSE="Sleepycat BSD"
+SLOT="3.3"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+S=${WORKDIR}/${P/db-/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ epatch "${FILESDIR}"/${P}-optional-test.patch
+ rm -rf docs
+ cd lib || die
+ rm -v *jar || die
+ java-pkg_jar-from --build-only ant-core ant.jar
+}
+
+EANT_DOC_TARGET="javadoc-all"
+EANT_EXTRA_ARGS="-Dnotest=true"
+
+src_install() {
+ java-pkg_dojar build/lib/je.jar
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/com
+}
diff --git a/dev-db/db-je/files/db-je-3.3.75-optional-test.patch b/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
new file mode 100644
index 000000000000..e8f7600398e2
--- /dev/null
+++ b/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
@@ -0,0 +1,45 @@
+--- build.xml 2008-06-11 05:25:20.000000000 +0200
++++ build.xml.new 2008-08-22 15:59:53.000000000 +0200
+@@ -102,6 +102,7 @@
+ <path id="empty.classpath"/>
+
+ <path id="class.path">
++ <fileset dir="lib" includes="*.jar"/>
+ <pathelement location="${specificjar}"/>
+ <pathelement location="."/>
+ </path>
+@@ -487,14 +488,14 @@
+ <!-- JUnit unit tests -->
+ <!-- ============================================================ -->
+
+- <target name="init-unittest" depends="init">
++ <target name="init-unittest" depends="init" unless="notest">
+ <delete dir="${unittest.datadir}"/>
+ <delete dir="${unittest.reportsdir}"/>
+ <mkdir dir="${unittest.datadir}"/>
+ <mkdir dir="${unittest.reportsdir}"/>
+ </target>
+
+- <target name="clean-unittest" depends="init-unittest">
++ <target name="clean-unittest" depends="init-unittest" unless="notest">
+ <delete dir="${unittest.destdir}"/>
+ <mkdir dir="${unittest.destdir}"/>
+ <delete dir="${unittest.testserialdir}"/>
+@@ -503,7 +504,7 @@
+ <mkdir dir="${unittest.testevolvedir}"/>
+ </target>
+
+- <target name="compile-unittest" depends="compile-src">
++ <target name="compile-unittest" depends="compile-src" unless="notest">
+ <ant antfile="ant/compile.xml" dir="." inheritall="false">
+ <property name="srcdir" value="${unittest.srcdir}"/>
+ <property name="destdir" value="${unittest.destdir}"/>
+@@ -597,7 +598,7 @@
+ </path>
+
+ <target name="test"
+- depends="compile-unittest, init-unittest, jar">
++ depends="compile-unittest, init-unittest, jar" unless="notest">
+
+ <!-- Determine which tests to run. -->
+ <condition property="alltests">
diff --git a/dev-db/db-je/metadata.xml b/dev-db/db-je/metadata.xml
new file mode 100644
index 000000000000..59b15e8a41aa
--- /dev/null
+++ b/dev-db/db-je/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+<herd>java</herd>
+</pkgmetadata>
+