summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-11-19 21:30:27 +0100
committerDavid Seifert <soap@gentoo.org>2022-11-19 21:30:27 +0100
commitb8bd80dea895c761a826d6757e1b64f0a947426a (patch)
tree532aafb350a39182c15e44b52008a3f9a724ce5d /dev-cpp
parentsys-cluster/pmix: update HOMEPAGE, SRC_URI (diff)
downloadgentoo-b8bd80dea895c761a826d6757e1b64f0a947426a.tar.gz
gentoo-b8bd80dea895c761a826d6757e1b64f0a947426a.tar.bz2
gentoo-b8bd80dea895c761a826d6757e1b64f0a947426a.zip
dev-cpp/sol2: drop 3.2.2
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sol2/Manifest1
-rw-r--r--dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch27
-rw-r--r--dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch10
-rw-r--r--dev-cpp/sol2/sol2-3.2.2.ebuild80
4 files changed, 0 insertions, 118 deletions
diff --git a/dev-cpp/sol2/Manifest b/dev-cpp/sol2/Manifest
index 1c68bf805c6d..a869853e1dd1 100644
--- a/dev-cpp/sol2/Manifest
+++ b/dev-cpp/sol2/Manifest
@@ -1,2 +1 @@
-DIST sol2-3.2.2.tar.gz 8531029 BLAKE2B 65fd220f5109e4917d06d5ef906ceccb7e292276f69bd49dfd826089a77e566af1811fdf660ffbfbd2437dca4b86ef5c4790dace9029805926e1ee0445b2e965 SHA512 e5a739b37aea7150f141f6a003c2689dd33155feed5bb3cf2569abbfe9f0062eacdaaf346be523d627f0e491b35e68822c80e1117fa09ece8c9d8d5af09fdbec
DIST sol2-3.3.0.tar.gz 8453838 BLAKE2B dd4ae6471913a8e5de51c248d22b2b30a0ef29a597c5181026ac175d789836b9ea4c278db6860a360b1b2d59a2063a7538dfb06044cd89cfdf6612a7f60ecd63 SHA512 f1eba8f9ea270a3a3fff9c7a036d130ec848d065e54a8aefd2a19ad7f17dcb6b5744d979fac54c765e8317a4cdcf72e1b9d622d114f48c6502cf2db900c8d4a3
diff --git a/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch b/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
deleted file mode 100644
index 2da3c00c1612..000000000000
--- a/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Use catch library from system
-
---- a/tests/runtime_tests/CMakeLists.txt
-+++ b/tests/runtime_tests/CMakeLists.txt
-@@ -22,12 +22,6 @@
-
- # # # # sol3 tests - runtime tests
-
--if (CMAKE_GENERATOR MATCHES "Visual Studio 14 2015")
-- find_package(Catch 1.12.1 REQUIRED)
--else()
-- find_package(Catch REQUIRED)
--endif()
--
- file(GLOB SOL2_RUNTIME_TEST_SOURCES source/*.cpp)
- source_group(test_sources FILES ${SOL2_RUNTIME_TEST_SOURCES})
-
-@@ -38,7 +32,8 @@ function(CREATE_TEST test_target_name test_name target_sol)
- OUTPUT_NAME ${test_name}
- EXPORT_NAME sol2::${test_name})
- target_link_libraries(${test_target_name}
-- PUBLIC Threads::Threads ${LUA_LIBRARIES} ${CATCH_LIBRARIES} ${target_sol})
-+ PUBLIC Threads::Threads ${LUA_LIBRARIES} ${target_sol})
-+ target_include_directories(${test_target_name} PRIVATE ${CATCH_INC_DIR})
-
- if (MSVC)
- if (NOT CMAKE_COMPILER_ID MATCHES "Clang")
diff --git a/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch b/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch
deleted file mode 100644
index cc8c6bb1b4f7..000000000000
--- a/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Add missing include needed for tests (and possibly consumers) with gcc11.
-
-Fixed upstream in:
-https://github.com/ThePhD/sol2/commit/e5e6466e09b632677d24a8f204d6a0ea0a8862b1
---- a/include/sol/stack_core.hpp
-+++ b/include/sol/stack_core.hpp
-@@ -42,2 +42,3 @@
- #include <string>
-+#include <limits>
- #include <algorithm>
diff --git a/dev-cpp/sol2/sol2-3.2.2.ebuild b/dev-cpp/sol2/sol2-3.2.2.ebuild
deleted file mode 100644
index 8af75c6deec7..000000000000
--- a/dev-cpp/sol2/sol2-3.2.2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1,3,4} luajit )
-inherit cmake lua
-
-DESCRIPTION="Header-only C++ <-> Lua API wrapper"
-HOMEPAGE="https://github.com/ThePhD/sol2"
-SRC_URI="https://github.com/ThePhD/sol2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-REQUIRED_USE="test? ( ${LUA_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- ${LUA_DEPS}
- dev-cpp/catch:0
- )
-"
-BDEPEND="
- test? (
- virtual/pkgconfig
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc11.patch
- "${FILESDIR}"/${P}-luajit-pkgconf.patch
- "${FILESDIR}"/${P}-catch-depend.patch
-)
-
-src_prepare() {
- # TODO: remove this sed on next bump
- sed -i -e 's/-Werror//' \
- tests/runtime_tests/CMakeLists.txt \
- tests/regression_tests/1011/CMakeLists.txt \
- tests/config_tests/function_pointers/CMakeLists.txt \
- examples/customization/CMakeLists.txt \
- examples/CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- cmake_src_configure
-
- if use test; then
- sol2_configure_wrapper() {
- local mycmakeargs=(
- -DSOL2_BUILD_LUA=no
- -DSOL2_TESTS=yes
- -DSOL2_LUA_VERSION="${ELUA}"
- -DCATCH_INC_DIR="${ESYSROOT}/usr/include/catch2"
- )
- cmake_src_configure
- }
- lua_foreach_impl sol2_configure_wrapper
- fi
-}
-
-src_compile() {
- use test && lua_foreach_impl cmake_src_compile
-}
-
-src_test() {
- sol2_test_wrapper() {
- if [[ ${ELUA} == luajit ]]; then
- einfo "Skipping test due to https://github.com/ThePhD/sol2/issues/1221"
- else
- cmake_src_test
- fi
- }
- lua_foreach_impl sol2_test_wrapper
-}