summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-17 20:09:37 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-17 20:09:37 +0200
commite3b3a737959067f75b36a2682d6b521bc3b1ad25 (patch)
tree7a0b155c699f0cc8f468038ccf50dd63ba465f6b /dev-cpp/xsimd
parentsci-libs/evaluate: add datasets deps (diff)
downloadgentoo-e3b3a737959067f75b36a2682d6b521bc3b1ad25.tar.gz
gentoo-e3b3a737959067f75b36a2682d6b521bc3b1ad25.tar.bz2
gentoo-e3b3a737959067f75b36a2682d6b521bc3b1ad25.zip
dev-cpp/xsimd: add 11.1.0, drop 11.0.0
Closes: https://bugs.gentoo.org/906359 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-cpp/xsimd')
-rw-r--r--dev-cpp/xsimd/Manifest2
-rw-r--r--dev-cpp/xsimd/files/xsimd-11.1.0-c++17.patch27
-rw-r--r--dev-cpp/xsimd/xsimd-11.1.0.ebuild (renamed from dev-cpp/xsimd/xsimd-11.0.0.ebuild)2
3 files changed, 30 insertions, 1 deletions
diff --git a/dev-cpp/xsimd/Manifest b/dev-cpp/xsimd/Manifest
index 53212822b10f..11ae1449e178 100644
--- a/dev-cpp/xsimd/Manifest
+++ b/dev-cpp/xsimd/Manifest
@@ -1 +1 @@
-DIST xsimd-11.0.0.tar.gz 218589 BLAKE2B ce0021f51d541d8c713645c84c38df2cf0e769fba191ba1ef030da682aa6176467cc1cc2722feac4bc0d3f931e1611d16349818eb9b4e9e1803d39f0985ecfbd SHA512 75927ab1369aa8eb321d4a2e425f14d977cd1a5792d13a8ca5a393b030fce7a5ce00492a5145a3fbedd29c3ad38556d5a4b2242534eb76dc5164b7cef4f8406b
+DIST xsimd-11.1.0.tar.gz 219350 BLAKE2B 2bbbc4f7dbe489a407fe798b146c008aba44664efc943c2e1507d5c6e7da2a03ed91abf0d872e5abf9bd94be3e76bef276ec5b47d4e356b42a7b4c680bd6f3d9 SHA512 3a6141dfa4d95a977f4222880dfd06197613d153a78a84653022423279eec037ea9def08ae225aba7231c0b2c434ab7c907c965f8367fb0db9b96113980b51f3
diff --git a/dev-cpp/xsimd/files/xsimd-11.1.0-c++17.patch b/dev-cpp/xsimd/files/xsimd-11.1.0-c++17.patch
new file mode 100644
index 000000000000..b0c99452cc4e
--- /dev/null
+++ b/dev-cpp/xsimd/files/xsimd-11.1.0-c++17.patch
@@ -0,0 +1,27 @@
+--- a/test/CMakeLists.txt 2023-05-17 19:59:34.023146040 +0200
++++ b/test/CMakeLists.txt 2023-05-17 20:01:23.021505635 +0200
+@@ -50,20 +50,11 @@
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wunused-parameter -Wextra -Wreorder")
+ # Users may override the c++ standard:
+ if(NOT DEFINED CMAKE_CXX_STANDARD OR "${CMAKE_CXX_STANDARD}" STREQUAL "")
+- if (ENABLE_XTL_COMPLEX)
+- CHECK_CXX_COMPILER_FLAG("-std=c++14" HAS_CPP14_FLAG)
+- if (NOT HAS_CPP14_FLAG)
+- message(FATAL_ERROR "Unsupported compiler -- xsimd requires C++14 support when xtl complex support is enabled")
+- endif()
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
+- else()
+- CHECK_CXX_COMPILER_FLAG("-std=c++11" HAS_CPP11_FLAG)
+- if (NOT HAS_CPP11_FLAG)
+- message(FATAL_ERROR "Unsupported compiler -- xsimd requires C++11 support!")
+- else()
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+- endif()
++ CHECK_CXX_COMPILER_FLAG("-std=c++17" HAS_CPP17_FLAG)
++ if (NOT HAS_CPP17_FLAG)
++ message(FATAL_ERROR "Unsupported compiler -- xsimd requires C++17 support")
+ endif()
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17")
+ endif()
+
+ if (NOT CROSS_COMPILE_ARM)
diff --git a/dev-cpp/xsimd/xsimd-11.0.0.ebuild b/dev-cpp/xsimd/xsimd-11.1.0.ebuild
index ef4c7e854109..b1393fb6ae04 100644
--- a/dev-cpp/xsimd/xsimd-11.0.0.ebuild
+++ b/dev-cpp/xsimd/xsimd-11.1.0.ebuild
@@ -25,6 +25,8 @@ BDEPEND="
)
test? ( dev-cpp/doctest )"
+PATCHES=( "${FILESDIR}"/${P}-c++17.patch )
+
src_prepare() {
sed -i \
-e '/fPIC/d' \