summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-24 14:22:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-24 14:22:50 +0200
commite6f152df07b3669b0f4bfd81cb542973332219f2 (patch)
tree27e07f57c2a5a760355b6e7c09df8a12fb4225ee /dev-cpp/libcmis
parentdev-cpp/libcmis: 0.5.2-r1 amd64/x86 stable (diff)
downloadgentoo-e6f152df07b3669b0f4bfd81cb542973332219f2.tar.gz
gentoo-e6f152df07b3669b0f4bfd81cb542973332219f2.tar.bz2
gentoo-e6f152df07b3669b0f4bfd81cb542973332219f2.zip
dev-cpp/libcmis: Drop 0.5.2 (r0)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/libcmis-0.5.2.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-cpp/libcmis/libcmis-0.5.2.ebuild b/dev-cpp/libcmis/libcmis-0.5.2.ebuild
deleted file mode 100644
index bd2e18fadf28..000000000000
--- a/dev-cpp/libcmis/libcmis-0.5.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-fi
-inherit autotools flag-o-matic
-
-DESCRIPTION="C++ client library for the CMIS interface"
-HOMEPAGE="https://github.com/tdf/libcmis"
-
-LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.5"
-
-IUSE="man static-libs test"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/libxml2
- net-misc/curl
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- man? (
- app-text/docbook2X
- dev-libs/libxslt
- )
- test? (
- dev-util/cppcheck
- dev-util/cppunit
- )
-"
-
-RESTRICT="test"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # bug 618778
- append-cxxflags -std=c++14
-
- local myeconfargs=(
- --program-suffix=-$(ver_cut 1-2)
- --disable-werror
- $(use_with man)
- $(use_enable static-libs static)
- $(use_enable test tests)
- --enable-client
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}