summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-12 02:59:50 -0500
committerTim Harder <radhermit@gentoo.org>2016-03-12 02:59:50 -0500
commitd97036b591cf9704dcac9ee7199676e16aa6004b (patch)
tree41c8f36d5cf722e1c7dcff1a02e0422ecd5930de /app-vim
parentmedia-sound/frescobaldi: version bump to 2.18.2 (diff)
downloadgentoo-d97036b591cf9704dcac9ee7199676e16aa6004b.tar.gz
gentoo-d97036b591cf9704dcac9ee7199676e16aa6004b.tar.bz2
gentoo-d97036b591cf9704dcac9ee7199676e16aa6004b.zip
app-vim/airline: version bump to 0.8
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/airline/Manifest1
-rw-r--r--app-vim/airline/airline-0.8.ebuild27
-rw-r--r--app-vim/airline/airline-9999.ebuild8
3 files changed, 32 insertions, 4 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
index 39d3ff458023..2381d84089b7 100644
--- a/app-vim/airline/Manifest
+++ b/app-vim/airline/Manifest
@@ -1 +1,2 @@
DIST airline-0.7.tar.gz 54318 SHA256 5d6b8840ccef133662f420fb1dba132d54bf0f5cc663657945e6cbea7e4b609e SHA512 5e8b072538d8c19083bb4fe6e5f8a5df76cf00735eb8a8a08078fba33d5fc25d89f49b9d9e07276e1661748b04901f1bfdf52d054330931785eab3df71a496b5 WHIRLPOOL c664423ebfbc1e830feb81aa4573c991388756396263fdf3cd0f37b8391b673f94c6eda0cff1c7517ab7fb5de7735ac39a8d066212ea43bd03ef82e2e9aff71c
+DIST airline-0.8.tar.gz 52767 SHA256 5fb1cdcd9a760516a050bd0e3fa4cae04291cfccd2bcf58f2facbd2a07767a14 SHA512 51ae20f7e5b869f714e9c21ab6ab8af4d2de31b3cf4fe9f6bd64e75e87e7796184d41ddd9536f3e41dcc93e9ca6aad684b286df6e5d8d6eae202f91ed8851292 WHIRLPOOL a5ccf7662267c25b6855d6df81c4c3f35bffe5c2001f05808c1e0a861bb6b04b0bc04d979b04a060992626406cd84d7ac8aabd73f29afaf286fbf4dbc3dec47c
diff --git a/app-vim/airline/airline-0.8.ebuild b/app-vim/airline/airline-0.8.ebuild
new file mode 100644
index 000000000000..01233b56c1af
--- /dev/null
+++ b/app-vim/airline/airline-0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove unwanted files
+ rm -rf t Gemfile Rakefile LICENSE README*
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
index c19b1c326317..01233b56c1af 100644
--- a/app-vim/airline/airline-9999.ebuild
+++ b/app-vim/airline/airline-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,16 +8,16 @@ inherit vim-plugin
if [[ ${PV} != 9999* ]] ; then
MY_PN=vim-${PN}
MY_P=${MY_PN}-${PV}
- SRC_URI="https://github.com/bling/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S=${WORKDIR}/${MY_P}
else
inherit git-r3
- EGIT_REPO_URI="https://github.com/bling/vim-airline.git"
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
fi
DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
-HOMEPAGE="https://github.com/bling/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
LICENSE="MIT"
VIM_PLUGIN_HELPFILES="${PN}.txt"