summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-21 14:45:44 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 16:57:51 +0200
commitf1448b354ef4d5204520103ab87b6334ca8bba51 (patch)
tree89a26d9143abff37605e213f0d0c70253d2ebffa /app-vim/vimoutliner
parentdev-python/mypy: Bump to 0.781 (diff)
downloadgentoo-f1448b354ef4d5204520103ab87b6334ca8bba51.tar.gz
gentoo-f1448b354ef4d5204520103ab87b6334ca8bba51.tar.bz2
gentoo-f1448b354ef4d5204520103ab87b6334ca8bba51.zip
app-vim/vimoutliner: add back Python 3 support.
Closes: https://bugs.gentoo.org/708392 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim/vimoutliner')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
index e35b5c0b1473..67a530a89de9 100644
--- a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
inherit python-single-r1 vim-plugin vcs-snapshot
@@ -22,16 +22,19 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/autopep8[${PYTHON_MULTI_USEDEP}]
- ')"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/autopep8[${PYTHON_MULTI_USEDEP}]')
+"
+
+DEPEND="
+ ${RDEPEND}"
src_prepare() {
default
- sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py || die
+ sed -e '1s:^:#!/usr/bin/python\n:' \
+ -i "${S}"/vimoutliner/scripts/otl2latex/otl2latex.py || die
find "${S}" -type f -exec chmod a+r {} \; || die
}
@@ -39,7 +42,8 @@ src_compile() {
local pyscript _pyscript
for pyscript in $(find "${S}" -type f -name \*.py); do
_pyscript=$(basename "${pyscript}")
- [ ${_pyscript} == "otl.py" ] && continue
- python_fix_shebang -q "${pyscript}"
+ [[ ${_pyscript} == "otl.py" ]] && continue
+ 2to3 -w -n --no-diffs "${pyscript}" >& /dev/null || die
+ python_fix_shebang -f -q "${pyscript}"
done
}