summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-06-25 17:39:08 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-06-25 17:39:35 +0200
commite2804242c6fc3fe022327b24fe16e0cb2daf95b6 (patch)
tree9807d46d22957b516641fb5a2c9f406be2ba969b /app-text
parentapp-text/kramdown-rfc: add 1.6.35 (diff)
downloadgentoo-e2804242c6fc3fe022327b24fe16e0cb2daf95b6.tar.gz
gentoo-e2804242c6fc3fe022327b24fe16e0cb2daf95b6.tar.bz2
gentoo-e2804242c6fc3fe022327b24fe16e0cb2daf95b6.zip
app-text/xml2rfc: add 3.17.4
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xml2rfc/Manifest1
-rw-r--r--app-text/xml2rfc/xml2rfc-3.17.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/xml2rfc/Manifest b/app-text/xml2rfc/Manifest
index a3150a78b894..82c9426f2ce7 100644
--- a/app-text/xml2rfc/Manifest
+++ b/app-text/xml2rfc/Manifest
@@ -1,2 +1,3 @@
DIST xml2rfc-3.16.0.gh.tar.gz 2859379 BLAKE2B 537815a648b9f5ed59b37a82a29ee092b7e2ad3d10c191a08c752a43d3aed0b81270a855b3a3ee1df935a1d14192715e62f82fe15c2de98eddf329ac554a4ba5 SHA512 893a71bd33c6971103188e624b91d1370f8324bb2316a542fa9496c02368875582b57336e57abd8753e207d80a5aed508c15407ea734056f91002dde9aafdad2
DIST xml2rfc-3.17.1.gh.tar.gz 2856471 BLAKE2B 81c0ba0788e6a7e5211186f87d06bf76622fae57557e62bfe3a9fbb9c3aa31de0e1e99302b28b81d4e7280a2f29704389c6a0936b20b0aee219576eff9bfc803 SHA512 d502afc37e350dfd4c578d160e3942c3a33ebf45941db1478cd8e88b3f00470ab457a44667dd0eb955a270e31ae528a73d3625f1a61aabb166705b3d367df62a
+DIST xml2rfc-3.17.4.gh.tar.gz 2858770 BLAKE2B b29b8a102668a5aa943a32b28a9d1669e2a6b0af03085a550c21a08e5bfb5ff3ee8979b03a3d7ae8e820ac8bf60455682914fd06a882e17183ca51aaf1dedf86 SHA512 3fc620eed12fc2a7f6015df8b6a5b1aa422cd8c26807e01d75498aee9257faad1bca68606f77598fb040a8dae074e35ffa0e2994a1ae8d59ee27d25fc6a755e5
diff --git a/app-text/xml2rfc/xml2rfc-3.17.4.ebuild b/app-text/xml2rfc/xml2rfc-3.17.4.ebuild
new file mode 100644
index 000000000000..3b8c97ef1ad8
--- /dev/null
+++ b/app-text/xml2rfc/xml2rfc-3.17.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
+HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc"
+SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+RESTRICT="!test? ( test )"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/dict2xml[${PYTHON_USEDEP}]
+ dev-python/weasyprint[${PYTHON_USEDEP}]
+ media-fonts/noto[cjk]
+ )
+"
+
+RDEPEND="
+ >=dev-python/platformdirs-3.6.0[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/intervaltree[${PYTHON_USEDEP}]
+ >=dev-python/google-i18n-address-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # Disable broken PdfWriterTests.
+ sed -i 's/ PdfWriterTests(unittest.TestCase):/ PdfWriterTests:/' test.py || die
+}