summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-19 22:26:19 +0100
committerSam James <sam@gentoo.org>2023-06-19 22:26:52 +0100
commit71d0d48fe392b55b1ed9fdd3727d9dd4a9310ca2 (patch)
tree91ca2c8156001a16cd57b474eba3931f09476e21 /app-text
parentdev-util/astyle: add 3.4 (diff)
downloadgentoo-71d0d48fe392b55b1ed9fdd3727d9dd4a9310ca2.tar.gz
gentoo-71d0d48fe392b55b1ed9fdd3727d9dd4a9310ca2.tar.bz2
gentoo-71d0d48fe392b55b1ed9fdd3727d9dd4a9310ca2.zip
app-text/ansifilter: avoid dep on glib for headless
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ansifilter/ansifilter-2.20.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/app-text/ansifilter/ansifilter-2.20.ebuild b/app-text/ansifilter/ansifilter-2.20.ebuild
index a317a56f20a2..7eee836705dd 100644
--- a/app-text/ansifilter/ansifilter-2.20.ebuild
+++ b/app-text/ansifilter/ansifilter-2.20.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop toolchain-funcs qmake-utils xdg
+inherit desktop toolchain-funcs qmake-utils xdg-utils
DESCRIPTION="Handles text files containing ANSI terminal escape codes"
HOMEPAGE="http://www.andre-simon.de/"
@@ -72,13 +72,22 @@ src_install() {
}
pkg_preinst() {
- use gui && xdg_pkg_preinst
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
}
pkg_postrm() {
- use gui && xdg_pkg_postrm
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
}
pkg_postinst() {
- use gui && xdg_pkg_postinst
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
}