summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/wklej
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/wklej')
-rw-r--r--app-text/wklej/Manifest2
-rw-r--r--app-text/wklej/metadata.xml12
-rw-r--r--app-text/wklej/wklej-0.2.0.ebuild37
-rw-r--r--app-text/wklej/wklej-0.2.1-r1.ebuild36
4 files changed, 87 insertions, 0 deletions
diff --git a/app-text/wklej/Manifest b/app-text/wklej/Manifest
new file mode 100644
index 000000000000..9c0fdd708c83
--- /dev/null
+++ b/app-text/wklej/Manifest
@@ -0,0 +1,2 @@
+DIST wklej-0.2.0.tar.gz 4356 SHA256 ba522500a0b48515498c98c9859f171893dd7bddc35e26e80adaa73ee8da8fe5 SHA512 5ae06c2aa09bb4ef84244efad46291f77fbbb01440d5369d25161112db18e2991cb6f7bfe49029aaef818d585be0a5a309e384419da23957e87b1613d43aaee5 WHIRLPOOL e605336dca7d4c874e6b6657cef8c7a05c3d233a82acbd8250c7f809f0353e1748b828bf63fca47e51d942ff47e82707c35d544e85397625fa6c00e698379faf
+DIST wklej-0.2.1.tar.gz 4370 SHA256 6b907351b3c10f70e847d0d761615e2b37f09696ad019da583325e6c17524dd1 SHA512 3799a1570f0cc7f1005f69484ceb1c6c88c8a24933beb3e32c0acd758ce29a5a1b6599baeea2b6405ec2da1e4fcb25b2d218b8295c68fa811fa4d53ada96cf0c WHIRLPOOL 8beda97607353bbfbd6e10a1ec91c060db42b74f258020eca9a4160e9f9a3197b9e936763ac37d7083b44b732f9ac64885c3d5445876d7ae404f0790a97b1351
diff --git a/app-text/wklej/metadata.xml b/app-text/wklej/metadata.xml
new file mode 100644
index 000000000000..68cf49966571
--- /dev/null
+++ b/app-text/wklej/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+</maintainer>
+<use>
+ <flag name='vim'>Install the vim plugin allowing to paste
+ through ':Wklej'.</flag>
+</use>
+</pkgmetadata>
diff --git a/app-text/wklej/wklej-0.2.0.ebuild b/app-text/wklej/wklej-0.2.0.ebuild
new file mode 100644
index 000000000000..1660648123e6
--- /dev/null
+++ b/app-text/wklej/wklej-0.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="*:2.6"
+inherit eutils python
+
+DESCRIPTION="A wklej.org submitter"
+HOMEPAGE="http://wklej.org"
+SRC_URI="http://wklej.org/m/apps/wklej-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="+vim"
+
+DEPEND=""
+RDEPEND="vim? ( app-editors/vim[python] )"
+
+S=${WORKDIR}
+
+src_install() {
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins ${PN}.vim || die "Failed to install vim plugin"
+ fi
+
+ dobin ${PN} || die "Failed to install ${PN} script"
+ dodoc README wklejrc || die "Failed to install readme"
+}
+
+pkg_postinst() {
+ elog "There are lots of changes in ${PV} version"
+ elog "Check out the documents in /usr/share/doc/${PF}"
+}
diff --git a/app-text/wklej/wklej-0.2.1-r1.ebuild b/app-text/wklej/wklej-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..fc5e8469cdc0
--- /dev/null
+++ b/app-text/wklej/wklej-0.2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit python-single-r1
+
+DESCRIPTION="A wklej.org submitter"
+HOMEPAGE="http://wklej.org"
+SRC_URI="http://wklej.org/m/apps/wklej-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+vim"
+
+DEPEND=""
+RDEPEND="vim? ( app-editors/vim[python,$(python_gen_usedep 'python2*')] )"
+
+# the vim script works is python2-only...
+REQUIRED_USE="vim? ( ^^ ( $(python_gen_useflags 'python2*') ) )"
+
+S=${WORKDIR}
+
+src_install() {
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins ${PN}.vim
+ fi
+
+ python_doscript ${PN}
+ dodoc README wklejrc
+}