summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 12:48:03 +0000
committerSam James <sam@gentoo.org>2021-01-12 12:51:07 +0000
commit55d879cb14f57e7413bcb0563fd9f2513698d38e (patch)
tree4018003fd65e1ab6633ff2637681d3b1e3e08f4e /app-text/teckit/teckit-2.5.10.ebuild
parentapp-text/dvisvgm: bump to 2.11 (diff)
downloadgentoo-55d879cb14f57e7413bcb0563fd9f2513698d38e.tar.gz
gentoo-55d879cb14f57e7413bcb0563fd9f2513698d38e.tar.bz2
gentoo-55d879cb14f57e7413bcb0563fd9f2513698d38e.zip
app-text/teckit: bump to 2.5.10
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/teckit/teckit-2.5.10.ebuild')
-rw-r--r--app-text/teckit/teckit-2.5.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/teckit/teckit-2.5.10.ebuild b/app-text/teckit/teckit-2.5.10.ebuild
new file mode 100644
index 000000000000..2a65a4c4820a
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="https://github.com/silnrsi/teckit/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.1-mixcflagscxxflags.patch"
+)
+
+src_prepare() {
+ rm -f configure || die
+
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS README NEWS
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ cd "${S}/test" || die
+ chmod +x dotests.pl || die
+ ./dotests.pl || die "tests failed"
+}