summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2017-11-14 09:03:20 -0500
committerChris Reffett <creffett@gentoo.org>2017-11-14 09:04:08 -0500
commit35091c0e19d6bb95e53f62349a74af9ba370839c (patch)
tree4cd4c96f5ed04d554777c4fc0bd28bca43736247 /app-text/sword
parentdev-db/mysql-cluster: Include dev-perl/JSON as a test dep (diff)
downloadgentoo-35091c0e19d6bb95e53f62349a74af9ba370839c.tar.gz
gentoo-35091c0e19d6bb95e53f62349a74af9ba370839c.tar.bz2
gentoo-35091c0e19d6bb95e53f62349a74af9ba370839c.zip
app-text/sword: Fix automagic dep on clucene
Gentoo-Bug: 637398 Package-Manager: Portage-2.3.14, Repoman-2.3.5 RepoMan-Options: --force
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/files/sword-1.7.4-configure.patch23
-rw-r--r--app-text/sword/metadata.xml3
-rw-r--r--app-text/sword/sword-1.7.4-r1.ebuild (renamed from app-text/sword/sword-1.7.4.ebuild)11
3 files changed, 33 insertions, 4 deletions
diff --git a/app-text/sword/files/sword-1.7.4-configure.patch b/app-text/sword/files/sword-1.7.4-configure.patch
new file mode 100644
index 000000000000..a098addcd0d2
--- /dev/null
+++ b/app-text/sword/files/sword-1.7.4-configure.patch
@@ -0,0 +1,23 @@
+--- a/configure
++++ b/configure
+@@ -16893,7 +16895,7 @@
+ # ---------------------------------------------------------------------
+
+ # NOTE the $libdir hack at the end of the c[xx]flags. Apparently F16 finds that clucene is not multilib-save and places some include files in /usr/lib[64]/
++if test "x$with_clucene" != "xno"; then
+-with_clucene=no
+ if test "x$CLUCENE2_LIBS" != x; then
+ echo "clucene 2.x found - lucene searching options available"
+ AM_CXXFLAGS="$AM_CXXFLAGS $CLUCENE2_CFLAGS -DUSELUCENE -DCLUCENE2 -I$libdir"
+@@ -16914,6 +16912,11 @@
+ echo "lucene searching options not available"
+ fi
+ fi
++else
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: excluding support" >&5
++$as_echo "clucene manually disabled - excluding support" >&6; }
++with_clucene="no"
++fi
+
+ for ac_func in vsnprintf
+ do :
diff --git a/app-text/sword/metadata.xml b/app-text/sword/metadata.xml
index dd852d82e555..fb9230654d3a 100644
--- a/app-text/sword/metadata.xml
+++ b/app-text/sword/metadata.xml
@@ -9,4 +9,7 @@ The SWORD Project is the CrossWire Bible Society's free Bible software
project. Its purpose is to create tools that allow programmers and Bible
societies to write new Bible software more quickly and easily.
</longdescription>
+<use>
+ <flag name="clucene">Use <pkg>dev-cpp/clucene</pkg> for lucene search support</flag>
+</use>
</pkgmetadata>
diff --git a/app-text/sword/sword-1.7.4.ebuild b/app-text/sword/sword-1.7.4-r1.ebuild
index 2db87d10461d..be1fa4a33141 100644
--- a/app-text/sword/sword-1.7.4.ebuild
+++ b/app-text/sword/sword-1.7.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic
DESCRIPTION="Library for Bible reading software"
@@ -11,11 +11,12 @@ SRC_URI="http://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~x86-fbsd ~ppc-macos"
-IUSE="curl debug doc icu static-libs"
+IUSE="clucene curl debug doc icu static-libs"
RDEPEND="sys-libs/zlib
curl? ( net-misc/curl )
icu? ( dev-libs/icu:= )
+ clucene? ( dev-cpp/clucene )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -39,19 +40,21 @@ src_prepare() {
DataPath=${EPREFIX}/usr/share/${PN}/
EOF
epatch "${FILESDIR}/${PN}-1.7.4-gcc6.patch"
+ epatch "${FILESDIR}/${PN}-1.7.4-configure.patch"
+ eapply_user
}
src_configure() {
# TODO: Why is this here and can we remove it?
strip-flags
-
econf \
$(use_enable static-libs static) \
$(use_enable debug) \
--with-zlib \
$(use_with icu) \
--with-conf \
- $(use_with curl)
+ $(use_with curl) \
+ $(use_with clucene)
}
src_install() {