summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-08-22 15:06:16 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-08-22 15:09:32 +0200
commite84f05574ff398d732582f00b0dbb22071dd3518 (patch)
tree21cd048d877e6a9c4c343e4685ebb8f067b4d086 /app-text/pdfgrep
parentdev-debug/dtrace: elaborate on kprobes being bad (diff)
downloadgentoo-e84f05574ff398d732582f00b0dbb22071dd3518.tar.gz
gentoo-e84f05574ff398d732582f00b0dbb22071dd3518.tar.bz2
gentoo-e84f05574ff398d732582f00b0dbb22071dd3518.zip
app-text/pdfgrep: add 2.2.0
Closes: https://bugs.gentoo.org/933694 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/pdfgrep')
-rw-r--r--app-text/pdfgrep/Manifest1
-rw-r--r--app-text/pdfgrep/pdfgrep-2.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/pdfgrep/Manifest b/app-text/pdfgrep/Manifest
index e85ac0372024..0fde5861c685 100644
--- a/app-text/pdfgrep/Manifest
+++ b/app-text/pdfgrep/Manifest
@@ -1 +1,2 @@
DIST pdfgrep-2.1.2.tar.gz 197289 BLAKE2B 94d20649104f7b17adf2d99bdf2ce215cf16746c649f7ec77d58a41b90b13dd903d47b5ed2d35f56ca7ca12ae49cfb8a57004f9ad3ee6b8930f533b33d7d8463 SHA512 27bc4741e5203b2fd265815a22ad8d702b3455b2ae932641b040fc9ce615bc9ff0abef221eb2ec8aa59c79cb139d31184261d076f9731177129a473d62aa4e5c
+DIST pdfgrep-2.2.0.tar.gz 213237 BLAKE2B eedc41810a1b1b1e23323118c10617787364496ac224738a7b0b9b566c47b08e609788f9d8e1a3b56587be86833820acef58c53ba32dd9fdfc8cc3be89db5e68 SHA512 de39ccb266f30b32ec71083759553979a31f7220b4923a4c3c74e1001c2f2c0dbef17c00f8139ffe88eec2031c48a13f18a057c7523ad363689b0f5b004c420f
diff --git a/app-text/pdfgrep/pdfgrep-2.2.0.ebuild b/app-text/pdfgrep/pdfgrep-2.2.0.ebuild
new file mode 100644
index 000000000000..e0c242ff2d5a
--- /dev/null
+++ b/app-text/pdfgrep/pdfgrep-2.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A tool similar to grep which searches text in PDFs"
+HOMEPAGE="https://pdfgrep.org/"
+SRC_URI="https://www.pdfgrep.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+pcre test unac"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/poppler:=[cxx]
+ dev-libs/libgcrypt:0=
+ pcre? ( dev-libs/libpcre2:= )
+ unac? ( app-text/unac )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ test? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended
+ dev-util/dejagnu
+ )
+"
+
+DOCS="AUTHORS README.md NEWS.md"
+
+src_configure() {
+ econf \
+ $(use_with pcre libpcre) \
+ $(use_with unac)
+}