summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-05-14 17:59:38 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-05-14 17:59:38 +0700
commitd0d3eaa0f05e4044f2b7075c5ef0fab419bdb5d0 (patch)
tree7e524e28cd1c96bad958b148a85dd29ecdce6d35 /app-text/foliate
parentmedia-plugins/kodi-audioencoder-flac: drop 3.0.0-r1 (diff)
downloadgentoo-d0d3eaa0f05e4044f2b7075c5ef0fab419bdb5d0.tar.gz
gentoo-d0d3eaa0f05e4044f2b7075c5ef0fab419bdb5d0.tar.bz2
gentoo-d0d3eaa0f05e4044f2b7075c5ef0fab419bdb5d0.zip
app-text/foliate: DEPEND on webkit-gtk:4.1
disable automagick tests Closes: https://bugs.gentoo.org/893682 Closes: https://bugs.gentoo.org/728508 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/foliate')
-rw-r--r--app-text/foliate/files/foliate-validate.patch31
-rw-r--r--app-text/foliate/files/foliate-webkit.patch13
-rw-r--r--app-text/foliate/foliate-2.6.4-r3.ebuild59
3 files changed, 103 insertions, 0 deletions
diff --git a/app-text/foliate/files/foliate-validate.patch b/app-text/foliate/files/foliate-validate.patch
new file mode 100644
index 000000000000..45d2c42eef73
--- /dev/null
+++ b/app-text/foliate/files/foliate-validate.patch
@@ -0,0 +1,31 @@
+diff -r -U3 foliate-2.6.4.orig/data/meson.build foliate-2.6.4/data/meson.build
+--- foliate-2.6.4.orig/data/meson.build 2022-01-13 19:23:26.000000000 +0700
++++ foliate-2.6.4/data/meson.build 2023-05-14 13:08:00.443754308 +0700
+@@ -7,13 +7,6 @@
+ install_dir: join_paths(get_option('datadir'), 'applications')
+ )
+
+-desktop_utils = find_program('desktop-file-validate', required: false)
+-if desktop_utils.found()
+- test('Validate desktop file', desktop_utils,
+- args: [desktop_file]
+- )
+-endif
+-
+ appstream_file = i18n.merge_file(
+ input: 'com.github.johnfactotum.Foliate.metainfo.xml.in',
+ output: 'com.github.johnfactotum.Foliate.metainfo.xml',
+@@ -22,13 +15,6 @@
+ install_dir: join_paths(get_option('datadir'), 'metainfo')
+ )
+
+-appstream_util = find_program('appstream-util', required: false)
+-if appstream_util.found()
+- test('Validate appstream file', appstream_util,
+- args: ['validate', appstream_file]
+- )
+-endif
+-
+ install_data('com.github.johnfactotum.Foliate.gschema.xml',
+ install_dir: join_paths(get_option('datadir'), 'glib-2.0/schemas')
+ )
diff --git a/app-text/foliate/files/foliate-webkit.patch b/app-text/foliate/files/foliate-webkit.patch
new file mode 100644
index 000000000000..cb559bf0003d
--- /dev/null
+++ b/app-text/foliate/files/foliate-webkit.patch
@@ -0,0 +1,13 @@
+diff --git a/src/main.js b/src/main.js
+index 718d420..2ea2018 100644
+--- a/src/main.js
++++ b/src/main.js
+@@ -18,7 +18,7 @@ pkg.initFormat()
+ pkg.require({
+ 'Gio': '2.0',
+ 'Gtk': '3.0',
+- 'WebKit2': '4.0'
++ 'WebKit2': '4.1'
+ })
+
+ const { Gio, Gtk, Gdk, GLib, WebKit2 } = imports.gi
diff --git a/app-text/foliate/foliate-2.6.4-r3.ebuild b/app-text/foliate/foliate-2.6.4-r3.ebuild
new file mode 100644
index 000000000000..666dca3a88a1
--- /dev/null
+++ b/app-text/foliate/foliate-2.6.4-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="cs de es eu fr id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit meson python-any-r1 plocale xdg gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4.1[introspection]
+ sys-devel/gettext
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-webkit.patch "${FILESDIR}"/${PN}-validate.patch )
+
+src_prepare() {
+ default
+ python_fix_shebang build-aux/meson
+ xdg_environment_reset
+
+ plocale_find_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_install() {
+ meson_src_install
+ dosym com.github.johnfactotum.Foliate /usr/bin/foliate
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}