summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-12-25 12:16:38 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-12-25 12:16:38 +0700
commitb5c67440bb2c23a722b22b90308e5fc237c50c38 (patch)
tree320a2eaae3caf88233d047d2874f513fa581cb7f /app-text/crengine-ng
parentsys-fs/zfs: re-add ninja-added selinux flag to 2.1.7-r1 (diff)
downloadgentoo-b5c67440bb2c23a722b22b90308e5fc237c50c38.tar.gz
gentoo-b5c67440bb2c23a722b22b90308e5fc237c50c38.tar.bz2
gentoo-b5c67440bb2c23a722b22b90308e5fc237c50c38.zip
app-text/crengine-ng: bump to 0.9.3
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/crengine-ng')
-rw-r--r--app-text/crengine-ng/Manifest1
-rw-r--r--app-text/crengine-ng/crengine-ng-0.9.3.ebuild58
-rw-r--r--app-text/crengine-ng/metadata.xml4
3 files changed, 61 insertions, 2 deletions
diff --git a/app-text/crengine-ng/Manifest b/app-text/crengine-ng/Manifest
index 35b7fbbbad3e..8adbe4a7ac52 100644
--- a/app-text/crengine-ng/Manifest
+++ b/app-text/crengine-ng/Manifest
@@ -1 +1,2 @@
DIST crengine-ng-0.9.2.tar.bz2 3123671 BLAKE2B 7ecafc398e81fa9771f5728d0fa60fbc6c3fb883a56d09fc4857d92c3d2f997cbbc0d4ac9818bff82d38ffb110463b88663f3298380a15e83df7292dff461cc2 SHA512 09b6f8f9bb747d71258802741d0d8962808279122ed6f2791b2c3813b684bb515206bc8656128e129fc7bcc76bcbb2c485360adb3b60f51377b87f26a1874e05
+DIST crengine-ng-0.9.3.tar.bz2 3125528 BLAKE2B 49f3c99dda63987fefff55184522f635af4c792e96efdc337e5c42c97d5975658a52308d33e314337d20ba9b8c70d0c590c567db567a01cc46d060d059ee20df SHA512 4a393c3ebb5ccc2a94fc06fae34b037c0e5d725d1b58a30d7f19476f94dbeb86e7138a444a84b80f536afb2fbed06a8899c87e322303322066a1d35a5bcd70a9
diff --git a/app-text/crengine-ng/crengine-ng-0.9.3.ebuild b/app-text/crengine-ng/crengine-ng-0.9.3.ebuild
new file mode 100644
index 000000000000..f17cdaadf91a
--- /dev/null
+++ b/app-text/crengine-ng/crengine-ng-0.9.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Cross-platform library designed to implement e-book readers"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crengine-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+png +jpeg +gif +svg +chm +harfbuzz +fontconfig +libunibreak +fribidi +zstd +libutf8proc lto static-libs"
+
+CDEPEND="sys-libs/zlib
+ png? ( media-libs/libpng:0 )
+ jpeg? ( media-libs/libjpeg-turbo )
+ >=media-libs/freetype-2.10.0
+ harfbuzz? ( media-libs/harfbuzz:= )
+ libunibreak? ( dev-libs/libunibreak:= )
+ fribidi? ( dev-libs/fribidi )
+ zstd? ( app-arch/zstd:= )
+ libutf8proc? ( dev-libs/libutf8proc:= )
+ fontconfig? ( media-libs/fontconfig )"
+
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ ${CDEPEND}"
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(
+ -DCRE_BUILD_SHARED=ON
+ -DCRE_BUILD_STATIC=$(usex static-libs)
+ -DUSE_COLOR_BACKBUFFER=ON
+ -DWITH_LIBPNG=$(usex png)
+ -DWITH_LIBJPEG=$(usex jpeg)
+ -DWITH_FREETYPE=ON
+ -DWITH_HARFBUZZ=$(usex harfbuzz)
+ -DWITH_LIBUNIBREAK=$(usex libunibreak)
+ -DWITH_FRIBIDI=$(usex fribidi)
+ -DWITH_ZSTD=$(usex zstd)
+ -DWITH_UTF8PROC=$(usex libutf8proc)
+ -DUSE_GIF=$(usex gif)
+ -DUSE_NANOSVG=$(usex svg)
+ -DUSE_CHM=$(usex chm)
+ -DUSE_ANTIWORD=ON
+ -DUSE_FONTCONFIG=$(usex fontconfig)
+ -DUSE_SHASUM=OFF
+ -DBUILD_TOOLS=OFF
+ -DENABLE_UNITTESTING=OFF
+ -DENABLE_LTO=$(usex lto)
+ )
+ cmake_src_configure
+}
diff --git a/app-text/crengine-ng/metadata.xml b/app-text/crengine-ng/metadata.xml
index 19324ff37cd7..77c3ad3cd348 100644
--- a/app-text/crengine-ng/metadata.xml
+++ b/app-text/crengine-ng/metadata.xml
@@ -11,8 +11,8 @@
<description>upstream</description>
</maintainer>
<longdescription lang="en">
- A fork of coolreader. Supported formats are: fb2 (including fb2.zip), fb3, epub (without DRM),
- rtf, doc, docx, odt, html, chm, pdb, mobi (without DRM), txt, trc, prc.
+ A fork of coolreader engine. Supported formats are: fb2 (including fb2.zip), fb3,
+ epub (without DRM), rtf, doc, docx, odt, html, chm, pdb, mobi (without DRM), txt, trc, prc.
</longdescription>
<use>
<flag name="chm">Support chm format</flag>