summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-18 08:40:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-18 08:49:37 +0200
commitbbd9c800f98da76d62518e23b94216f109389159 (patch)
tree9573a071b64618e1c4a03aa0c34addfb9370197f /app-text/cb2bib
parentdev-perl/BSON: Bump to version 1.6.7 (diff)
downloadgentoo-bbd9c800f98da76d62518e23b94216f109389159.tar.gz
gentoo-bbd9c800f98da76d62518e23b94216f109389159.tar.bz2
gentoo-bbd9c800f98da76d62518e23b94216f109389159.zip
app-text/cb2bib: 1.9.8 version bump, fix build with Qt 5.11
Closes: https://bugs.gentoo.org/662764 Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'app-text/cb2bib')
-rw-r--r--app-text/cb2bib/Manifest1
-rw-r--r--app-text/cb2bib/cb2bib-1.9.8.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-text/cb2bib/Manifest b/app-text/cb2bib/Manifest
index 0df2a7f46258..baf069bb8ce5 100644
--- a/app-text/cb2bib/Manifest
+++ b/app-text/cb2bib/Manifest
@@ -1 +1,2 @@
DIST cb2bib-1.9.7.tar.gz 845121 BLAKE2B eafce83874e82c20a45de5dc4c1558aa40346821f26bf2d9f53332f337e5cdaffb92c70972fd8b99823f72615608ea848808c9875e16ed50f02cf1d9655d552e SHA512 87a438288c6e7776db136de63de1a8e27f2abf8499d28c0691b60ad3ef4f848e8987af4fc47d1f2cfb1d47009e28e7535f6bab998811cb721bfc9f384941b1e4
+DIST cb2bib-1.9.8.tar.gz 1180660 BLAKE2B 86a826a9285ecd5ecd266b3935ddfa330153cba4b28f378519b464719d5a2bcaa6043470d36ba5c443202a07a18bbaeb28c3371db07063f0d682b54d2a8fe373 SHA512 717f9b4de3e261e6d22a7e514e2ec5891723572f1624280edc8a980171f4dada6e177a3e95748fc39ff0ba1c137406e38dd14f43a0f1e0995c1f39992842f38a
diff --git a/app-text/cb2bib/cb2bib-1.9.8.ebuild b/app-text/cb2bib/cb2bib-1.9.8.ebuild
new file mode 100644
index 000000000000..295b6e26046f
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.9.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="https://www.molspaces.com/cb2bib/"
+SRC_URI="https://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+lzo webengine +webkit"
+
+REQUIRED_USE="?? ( webkit webengine )"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ lzo? ( dev-libs/lzo:2 )
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ webkit? ( dev-qt/qtwebkit:5 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS CHANGELOG COPYRIGHT )
+
+src_prepare() {
+ default
+
+ sed -i -e "s|../AUTHORS ../COPYRIGHT ../LICENSE ../CHANGELOG||" src/src.pro || die
+
+ use webengine || sed -i -e "s/qtHaveModule(webenginewidgets)/false/g" src/src.pro || die
+ use webkit || sed -i -e "s/qtHaveModule(webkitwidgets)/false/g" src/src.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ $(use !lzo && echo -config disable_lzo)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler[utils] - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+}