summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-09 21:19:48 -0400
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-09 18:22:09 -0700
commit3136e5c7033715f4c0224e75dc25fc91f0ab8851 (patch)
treef822440d4115c1cebb6b1821fc07679b7059f040 /app-shells/loksh/loksh-6.7.5.ebuild
parentmedia-video/baka-mplayer: add ~ppc64 keyword (diff)
downloadgentoo-3136e5c7033715f4c0224e75dc25fc91f0ab8851.tar.gz
gentoo-3136e5c7033715f4c0224e75dc25fc91f0ab8851.tar.bz2
gentoo-3136e5c7033715f4c0224e75dc25fc91f0ab8851.zip
app-shells/loksh: version bump to 6.7.5
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/17868 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells/loksh/loksh-6.7.5.ebuild')
-rw-r--r--app-shells/loksh/loksh-6.7.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-6.7.5.ebuild b/app-shells/loksh/loksh-6.7.5.ebuild
new file mode 100644
index 000000000000..ca44f5e3fd4f
--- /dev/null
+++ b/app-shells/loksh/loksh-6.7.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/${PN}/releases/download/${PV}/src.tar.xz -> ${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}