summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Winter <steffen.winter@proton.me>2024-02-28 11:58:26 +0100
committerYixun Lan <dlan@gentoo.org>2024-03-09 10:46:20 +0000
commitb7f8c5a1527a7acc9034ec86674db3eb441618d6 (patch)
tree5b6dbef83035c70011fc197ab75c77ad40eef2e2 /app-shells/fish
parentsys-process/fcron: update EAPI 7 -> 8 (diff)
downloadgentoo-b7f8c5a1527a7acc9034ec86674db3eb441618d6.tar.gz
gentoo-b7f8c5a1527a7acc9034ec86674db3eb441618d6.tar.bz2
gentoo-b7f8c5a1527a7acc9034ec86674db3eb441618d6.zip
app-shells/fish: add 3.7.0
Closes: https://github.com/gentoo/gentoo/pull/35565 Signed-off-by: Steffen Winter <steffen.winter@proton.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-3.7.0.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index 2acfb6f754bd..863399401199 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,2 +1,3 @@
DIST fish-3.4.0.tar.xz 3292216 BLAKE2B 3691e5387a8392d7d43b3b0f8b893e83e246c3532684e95a19c7b2eb4ebe80bcf04aaa1b965f5c4f6d782d0ae52269bb1cdafef76845b02f9f99d4c82ea77ce3 SHA512 463ee8d86815520c6de9777fd2b5975f06cc0842137c86cca7ae0331e95d74e755bf6f4b0bdea7e96c11371436ff9f97ce483ae026daa1e8d385f6cad8860ed4
DIST fish-3.6.1.tar.xz 2866100 BLAKE2B 13a41781c9a7ad093b18d4697c6087ef4c621bdf9cdc23c29ab89514fe990b38461c2323344e884cb95070c98976db1a37615f91281919a4ac36d6ca3312558a SHA512 ee6f5c7699307d515f111c8c4f1633d9eb9703e045a93cfc2fcec722a03cca4ab25e4e09f6fd94ff2d07180d8b37c6ab733323bb2645065fdeb4e94771347597
+DIST fish-3.7.0.tar.xz 2961912 BLAKE2B fd2c663a21be7a3aad362c69eff94f1cd9947075953deae74de64ef96b1d6f3874efa6389806f0eebc5789068acefb1218c6baaa1059a14ed13b5c33e6bc03e3 SHA512 bc5121ddd2a9918befac197b215721f20b69984897ec57558bef8e3a36a849935f6d1ec1c74c2d92e565f23e417039d7130122549c8b1d8c55dd8dbfb51a2d34
diff --git a/app-shells/fish/fish-3.7.0.ebuild b/app-shells/fish/fish-3.7.0.ebuild
new file mode 100644
index 000000000000..d11c8f1ca20c
--- /dev/null
+++ b/app-shells/fish/fish-3.7.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="Friendly Interactive SHell"
+HOMEPAGE="https://fishshell.com/"
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
+else
+ SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+doc nls split-usr test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libpcre2-10.32:=[pcre32]
+ sys-apps/coreutils
+ sys-libs/ncurses:=[unicode(+)]
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ dev-tcltk/expect
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# we don't need shpinx dep for release tarballs
+[[ ${PV} == 9999 ]] && DEPEND+=" doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_check_deps() {
+ use test || return 0
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ # workaround for https://github.com/fish-shell/fish-shell/issues/4883
+ if use split-usr; then
+ sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
+ cmake/Tests.cmake || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # installing into /bin breaks tests on merged usr systems.
+ # sbin -> bin symlink confuses tests.
+ # so on split-usr we install to /bin.
+ # on merge-usr we set sbindir to bin.
+ $(usex split-usr "-DCMAKE_INSTALL_BINDIR=${EPREFIX}/bin" \
+ "-DCMAKE_INSTALL_SBINDIR=${EPREFIX}/usr/bin")
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -DCURSES_NEED_NCURSES=ON
+ -DINSTALL_DOCS="$(usex doc)"
+ -DWITH_GETTEXT="$(usex nls)"
+ )
+ # release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
+ else
+ mycmakeargs+=( -DBUILD_DOCS=OFF )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ # some tests are fragile, sanitize environment
+ local -x COLUMNS=80
+ local -x LINES=24
+
+ # very fragile, depends on terminal, size, tmux, screen and timing
+ # no die is intentional, for repeated test runs
+ if [[ ${PV} != 9999 ]]; then
+ rm -v tests/pexpects/terminal.py || :
+ fi
+
+ # zfs completion test will fail with "Permission denied the ZFS utilities must be run as root."
+ mv "${S}"/share/completions/zfs.{fish,disabled} || die
+
+ # TODO: fix tests & submit upstream
+ # tests are confused by usr/sbin -> bin symlink, no die is intentional for repeated test runs
+ use split-usr || rm -v tests/checks/{redirect,type}.fish || :
+
+ cmake_build test
+
+ # now restore zfs completions
+ mv "${S}"/share/completions/zfs.{disabled,fish} || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_pkg_postinst
+}