summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-24 09:49:14 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-24 09:59:41 +0200
commit5c1bc9e62819784d1c15bbe9a6fdd0c8c53b3141 (patch)
treeb85ee3301398ec26b3e1d24dccc0eaba5dd80a04 /app-shells/fish
parentapp-arch/lziprecover: Removed old. (diff)
downloadgentoo-5c1bc9e62819784d1c15bbe9a6fdd0c8c53b3141.tar.gz
gentoo-5c1bc9e62819784d1c15bbe9a6fdd0c8c53b3141.tar.bz2
gentoo-5c1bc9e62819784d1c15bbe9a6fdd0c8c53b3141.zip
app-shells/fish: Bump to version 2.3.0
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-2.3.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index f14d51039b9b..193a95672583 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,3 +1,4 @@
DIST fish-2.1.1.tar.gz 1681744 SHA256 b7e4d3c3d55fc3859edcb20462fcf0d14ab26e920eddcd503072e8105284d924 SHA512 c6b41a7514d684bc165bdf03edd0f07b0cdfbcc827a3bcc6e9105bbf6b94a60962bd7fffaf5f9c44c450da3d4b6af4bdcf72fbbaaa043851c631d8c2a1344dd6 WHIRLPOOL c6bcbfea35d68f99903633f06a436cf982f6fc01123cebbb4342be1b3f3be106c0ac144d24b2069bf34bc7e3540d26526a8ef8b74e4f27255525ad0d7cb70774
DIST fish-2.1.2.tar.gz 1730198 SHA256 c6c20d5ca3a2a0168461de8abfe85f9e6b255132698ea0109998d4ab68f9f6dd SHA512 4f8f0133094d4d2295546a5b96e044646de2266364610368210b0db529b2d865c1b389f01f311b9b6d6d6dcd2a29040b7a9499d491605ae52a765a76d83db2a5 WHIRLPOOL 2a02dd0f91731cfc79de64245c34fc4361f42406d0c0a60afbafa08c2b9265d11c4adadc96ca5eb49b9053db1eb949c297eee23a7cbc63a30f56ce577b650779
DIST fish-2.2.0.tar.gz 2213037 SHA256 a76339fd14ce2ec229283c53e805faac48c3e99d9e3ede9d82c0554acfc7b77a SHA512 210047f56b105a3d372f03d3a2de41661ed18001e3c8fa053ae4aa43089118d4467837ea022bc44f9877ecc3d0563b365f97920c002faccebaa663c4f079e9e0 WHIRLPOOL 8b25e437e0c942255b5f39686008fb37ec45cea52e04b2d61facf1fdcd59510138dace506eadb17eb0074d175d3c1226d6e52d437e325ed5a90e22e696918d9d
+DIST fish-2.3.0.tar.gz 4537458 SHA256 912bac47552b1aa0d483a39ade330356632586a8f726c0e805b46d45cfad54e5 SHA512 acfeb8daad34250c626172428573d5baf86c43d37379fb29da296973931cb5e0b8d7cb5d2ed64eb6e3b984a3a65fc800dd8f78dce7d5e4719bc5dc143be27e8a WHIRLPOOL 1a9023540307fba2bf594ff785ae2f825e62addba920f312aeae6afaaf394cbb4a90f7fc205496ed49d7efb0cb460acd737e61af262bcbee3013d148e70ca9ed
diff --git a/app-shells/fish/fish-2.3.0.ebuild b/app-shells/fish/fish-2.3.0.ebuild
new file mode 100644
index 000000000000..154c96518a59
--- /dev/null
+++ b/app-shells/fish/fish-2.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses:0=
+ sys-devel/bc
+ sys-devel/gettext
+ X? ( x11-misc/xsel )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ emake test
+ else
+ ewarn "The test suite only works when the package is already installed"
+ fi
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
+ elog "browser of your choice to get acces to ${PN}'s help system:"
+ elog " BROWSER=\"/usr/bin/firefox\""
+ elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
+ elog "Have fun!"
+}