summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai-Chun Ning <kaichun.ning@gmail.com>2023-05-24 19:53:33 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-05-30 09:57:06 +0300
commit6812b8eaad94961cb6ca9182e17ac865cbff9b89 (patch)
treee730be6ad6740c5665807fe1f4b7731ee0a65bee /app-office
parentmedia-sound/flacon: Stabilize 10.0.0 amd64, #907266 (diff)
downloadgentoo-6812b8eaad94961cb6ca9182e17ac865cbff9b89.tar.gz
gentoo-6812b8eaad94961cb6ca9182e17ac865cbff9b89.tar.bz2
gentoo-6812b8eaad94961cb6ca9182e17ac865cbff9b89.zip
app-office/calcurse: add 4.8.1
Signed-off-by: Kai-Chun Ning <kaichun.ning@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31153 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/Manifest1
-rw-r--r--app-office/calcurse/calcurse-4.8.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
index 20f6730a0ddc..409d9e24cec2 100644
--- a/app-office/calcurse/Manifest
+++ b/app-office/calcurse/Manifest
@@ -1 +1,2 @@
DIST calcurse-4.8.0.tar.gz 716234 BLAKE2B 3fc703626d5e17b78ff42c0ef4f554585efd8223c2bd9d8c2f7add681602dc585cf066ed7c55a040b2585ad07513b26a5297b3b41f4c94a043f61ad2ad9094c2 SHA512 ea156c4320abf97fdb5abc29ff1f9bc659a3cab0e571295ed04b42dd742c4c45a7d5958dc2d386fc0ee7bd733969a6275405d5cf10cd645c75cb97b6b9e571d6
+DIST calcurse-4.8.1.tar.gz 730787 BLAKE2B 0c34b85313c3414dffc08635f6f37feb0a1e0f6c03bcf3b71a6cc95ed8fb4430ab1339abce72850364251884d707acb6cbbed0143d930f8bb76310ca5951b779 SHA512 a0a0bcfceb28a4e363168711a3c2de8f6e94d7f12aa78ff40f157c247ea6a41646bd218a1defba2d128b131ed0ab71c4d417820a0af0adbaa215011b11f0a040
diff --git a/app-office/calcurse/calcurse-4.8.1.ebuild b/app-office/calcurse/calcurse-4.8.1.ebuild
new file mode 100644
index 000000000000..fb8ab824f4b2
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="caldav doc"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/timezone-data
+ ${PYTHON_DEPS}
+ caldav? (
+ $(python_gen_cond_dep '
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc docs)
+ --without-asciidoc # do not use AsciiDoc to regenerate docs
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ if use caldav; then
+ python_fix_shebang contrib/caldav/calcurse-caldav
+ fi
+}
+
+src_install() {
+ docompress -x /usr/share/doc # decompress text files
+ default
+}