summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-25 17:47:17 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-25 17:47:51 +0100
commit42d09a765cb8ba8a11fe00b6d0084c71e30ec25f (patch)
treeb77dc38db663433f16e0cbb138cf0da2e0b11f6f /app-office
parentdev-python/setuptools: Resolve circular deps (diff)
downloadgentoo-42d09a765cb8ba8a11fe00b6d0084c71e30ec25f.tar.gz
gentoo-42d09a765cb8ba8a11fe00b6d0084c71e30ec25f.tar.bz2
gentoo-42d09a765cb8ba8a11fe00b6d0084c71e30ec25f.zip
app-office/libreoffice: Fix build with Gentoo glibc-2.23, bug 575108
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-5.1.0.3-isnan.patch23
-rw-r--r--app-office/libreoffice/libreoffice-5.1.0.3.ebuild3
-rw-r--r--app-office/libreoffice/libreoffice-5.1.9999.ebuild3
3 files changed, 29 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.1.0.3-isnan.patch b/app-office/libreoffice/files/libreoffice-5.1.0.3-isnan.patch
new file mode 100644
index 000000000000..6a15da565afb
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.1.0.3-isnan.patch
@@ -0,0 +1,23 @@
+From: Tomáš Chvátal <tchvatal@suse.com>
+Date: Thu, 25 Feb 2016 16:16:19 +0000 (+0100)
+Subject: Add std prefix to isnan check to fix build with glibc > 2.23
+X-Git-Url: https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff_plain;h=d7c64d6e430e9640c77c846006a13bbc78704c28
+
+Add std prefix to isnan check to fix build with glibc > 2.23
+
+Change-Id: I6321cd905152231bb013e25f7b268f85453fe917
+---
+
+diff --git a/xmloff/source/draw/ximp3dscene.cxx b/xmloff/source/draw/ximp3dscene.cxx
+index 5cf205f..525e2fb 100644
+--- a/xmloff/source/draw/ximp3dscene.cxx
++++ b/xmloff/source/draw/ximp3dscene.cxx
+@@ -66,7 +66,7 @@ SdXML3DLightContext::SdXML3DLightContext(
+ {
+ ::basegfx::B3DVector aVal;
+ SvXMLUnitConverter::convertB3DVector(aVal, sValue);
+- if (!isnan(aVal.getX()) && !isnan(aVal.getY()) && !isnan(aVal.getZ()))
++ if (!std::isnan(aVal.getX()) && !std::isnan(aVal.getY()) && !std::isnan(aVal.getZ()))
+ {
+ maDirection = aVal;
+ }
diff --git a/app-office/libreoffice/libreoffice-5.1.0.3.ebuild b/app-office/libreoffice/libreoffice-5.1.0.3.ebuild
index 18d7177985f9..fe6e54d1362a 100644
--- a/app-office/libreoffice/libreoffice-5.1.0.3.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.0.3.ebuild
@@ -257,6 +257,9 @@ REQUIRED_USE="
"
PATCHES=(
+ # submitted upstream
+ "${FILESDIR}/${PN}-5.1.0.3-isnan.patch"
+
# not upstreamable stuff
"${FILESDIR}/${PN}-4.4-system-pyuno.patch"
)
diff --git a/app-office/libreoffice/libreoffice-5.1.9999.ebuild b/app-office/libreoffice/libreoffice-5.1.9999.ebuild
index 18d7177985f9..fe6e54d1362a 100644
--- a/app-office/libreoffice/libreoffice-5.1.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.9999.ebuild
@@ -257,6 +257,9 @@ REQUIRED_USE="
"
PATCHES=(
+ # submitted upstream
+ "${FILESDIR}/${PN}-5.1.0.3-isnan.patch"
+
# not upstreamable stuff
"${FILESDIR}/${PN}-4.4-system-pyuno.patch"
)