summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/pybliographer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/pybliographer')
-rw-r--r--app-office/pybliographer/Manifest1
-rw-r--r--app-office/pybliographer/metadata.xml17
-rw-r--r--app-office/pybliographer/pybliographer-1.2.15-r1.ebuild67
3 files changed, 85 insertions, 0 deletions
diff --git a/app-office/pybliographer/Manifest b/app-office/pybliographer/Manifest
new file mode 100644
index 000000000000..8ac8c3279fd1
--- /dev/null
+++ b/app-office/pybliographer/Manifest
@@ -0,0 +1 @@
+DIST pybliographer-1.2.15.tar.gz 1859977 SHA256 dde66734e3839de92fe068c7804c1e580a049dfe91316df47ec0552236de6ce4 SHA512 f4b3478f60f042ebc7538f044a8c4014fda5202576e3f894b31c79430400e834c59f859f895efa187a89016f4e2625ee6be20751f31843e179fbdfb54ba65330 WHIRLPOOL 0bba23bce6deb39ec5efaac5c9e966c8e70853096e37fedfdb0dbcf41030247df715b55233977a0261c2a21c6e8cfb35b4cf6551ab2908baa889e4502ace0e92
diff --git a/app-office/pybliographer/metadata.xml b/app-office/pybliographer/metadata.xml
new file mode 100644
index 000000000000..15047be8bef5
--- /dev/null
+++ b/app-office/pybliographer/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <longdescription lang="en">
+ Pybliographer is a tool for managing bibliographic databases, with
+ the following features:
+ * a user-friendly Gnome interface for editing, searching, inserting
+ your citations in LyX, Kile and OpenOffice.org, searching external
+ databases like PubMed, Web of Science, Citeseer, and more.
+ * powerful APIs to integrate these features into your own custom
+ application, with your own specific database schema.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pybliographer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/pybliographer/pybliographer-1.2.15-r1.ebuild b/app-office/pybliographer/pybliographer-1.2.15-r1.ebuild
new file mode 100644
index 000000000000..315dfc062fdf
--- /dev/null
+++ b/app-office/pybliographer/pybliographer-1.2.15-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+GCONF_DEBUG="no"
+
+inherit autotools gnome2 python-single-r1
+
+DESCRIPTION="Pybliographer is a tool for working with bibliographic databases"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-text/recode-3.6-r1
+ app-text/scrollkeeper
+ dev-libs/glib:2
+ dev-python/gconf-python:2[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python:2[${PYTHON_USEDEP}]
+ dev-python/libgnome-python:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=dev-python/python-bibtex-1.2.5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+"
+
+src_prepare() {
+ # Workaround for bug 487204.
+ sed -i \
+ -e 's:\$(srcdir)/::g' \
+ tests/Makefile.am || die "sed failed"
+
+ # Install Python modules into site-packages directories.
+ find -name Makefile.am | xargs sed -i \
+ -e "/^pybdir[[:space:]]*=[[:space:]]*/s:\$(datadir):$(python_get_sitedir):" || die "sed failed"
+ sed -i \
+ -e "s:\${datadir}/@PACKAGE@:$(python_get_sitedir)/@PACKAGE@:" \
+ etc/installer.in || die "sed failed"
+ sed -i \
+ -e "s:gladedir = \$(datadir):gladedir = $(python_get_sitedir):" \
+ Pyblio/GnomeUI/glade/Makefile.am || die "sed failed"
+
+ # Fix shebang manually as otherwise python_fix_shebang gets confused
+ sed -i -e 's: @python_path@:/usr/bin/python2:' pybliographer.py || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-depchecks
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${D}"
+}