summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-10-06 17:06:04 +0200
committerSam James <sam@gentoo.org>2022-10-07 12:28:14 +0100
commit85ae38056b4c42f99e76210d844cf994cca7bd5a (patch)
treef580085d735251dbbee3afb22bbe8b40a408891f /app-misc
parentapp-misc/dvtm: sync live (diff)
downloadgentoo-85ae38056b4c42f99e76210d844cf994cca7bd5a.tar.gz
gentoo-85ae38056b4c42f99e76210d844cf994cca7bd5a.tar.bz2
gentoo-85ae38056b4c42f99e76210d844cf994cca7bd5a.zip
app-misc/dvtm: fix implicit function declaration issue
This commit patches the gentoo patch in such a way that compiler will search for curses.h in ncrusesw directory where addnwstr function is located. Closes: https://bugs.gentoo.org/870526 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/dvtm/files/dvtm-0.15-gentoo.patch5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-misc/dvtm/files/dvtm-0.15-gentoo.patch b/app-misc/dvtm/files/dvtm-0.15-gentoo.patch
index 3bb7dec3721f..22a3fe4ebf34 100644
--- a/app-misc/dvtm/files/dvtm-0.15-gentoo.patch
+++ b/app-misc/dvtm/files/dvtm-0.15-gentoo.patch
@@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
-@@ -10,12 +10,12 @@
+@@ -10,12 +10,13 @@ MANPREFIX = ${PREFIX}/share/man
TERMINFO := ${DESTDIR}${PREFIX}/share/terminfo
INCS = -I.
@@ -8,6 +8,7 @@
-CPPFLAGS = -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -D_XOPEN_SOURCE_EXTENDED
+LIBS = -lc -lutil $(shell $(PKG_CONFIG) --libs ncursesw)
+CPPFLAGS += -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -D_XOPEN_SOURCE_EXTENDED
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags ncursesw)
CFLAGS += -std=c99 ${INCS} -DVERSION=\"${VERSION}\" -DNDEBUG ${CPPFLAGS}
LDFLAGS += ${LIBS}
@@ -18,7 +19,7 @@
STRIP ?= strip
--- a/Makefile
+++ b/Makefile
-@@ -16,13 +16,13 @@
+@@ -16,13 +16,13 @@ config.h:
.c.o:
@echo CC $<